Anton Shterenlikht wrote:
On Wed, Jun 18, 2008 at 08:23:20PM +0100, Chris Whitehouse wrote:
Anton Shterenlikht wrote:
I sent a query to ImageMagick port maintainers about this.

I'm getting errors while trying to upgrade to
ImageMagick 6.4.1.5 on FreeBSD 7.0-release.

Below are the error messages and my ImageMagick configuration.

Please advise
many thanks
anton


[skip]

PASS: utilities/tests/wave.sh
PASS: utilities/tests/montage.sh
====================
All 697 tests passed
====================
cd PerlMagick && make CC='cc' test
/bin/sh ../magick.sh PERL_DL_NONLAZY=1 /usr/local/bin/perl5.8.8 "-MExtUtils::Command::MM" "-e" "test_harness(0, 'blib/lib', 'blib/arch')" t/*.t t/bzlib/*.t t/fpx/*.t t/jbig/*.t t/jpeg/*.t t/jp2/*.t t/png/*.t t/tiff/*.t t/wmf/*.t t/zlib/*.t
t/blob............dubious


       Test returned status 0 (wstat 139, 0x8b)
DIED. FAILED test 1
       Failed 1/1 tests, 0.00% okay
t/bzlib/read......dubious
       Test returned status 0 (wstat 139, 0x8b)
DIED. FAILED test 1
       Failed 1/1 tests, 0.00% okay
t/bzlib/write.....dubious
       Test returned status 0 (wstat 139, 0x8b)
DIED. FAILED test 1
       Failed 1/1 tests, 0.00% okay
t/composite.......dubious
       Test returned status 0 (wstat 139, 0x8b)
DIED. FAILED tests 1-18
       Failed 18/18 tests, 0.00% okay
t/filter..........dubious
       Test returned status 0 (wstat 139, 0x8b)
DIED. FAILED tests 1-58
       Failed 58/58 tests, 0.00% okay
t/fpx/read........dubious
       Test returned status 0 (wstat 139, 0x8b)
DIED. FAILED tests 1-5
       Failed 5/5 tests, 0.00% okay
t/fpx/write.......dubious
       Test returned status 0 (wstat 139, 0x8b)
DIED. FAILED tests 1-4
       Failed 4/4 tests, 0.00% okay
t/getattribute....dubious
       Test returned status 0 (wstat 139, 0x8b)
DIED. FAILED tests 1-25
       Failed 25/25 tests, 0.00% okay
t/jbig/read.......dubious
       Test returned status 0 (wstat 139, 0x8b)
DIED. FAILED test 1
       Failed 1/1 tests, 0.00% okay
t/jbig/write......dubious
       Test returned status 0 (wstat 139, 0x8b)
DIED. FAILED test 1
       Failed 1/1 tests, 0.00% okay
t/jp2/read........dubious
       Test returned status 0 (wstat 139, 0x8b)
DIED. FAILED tests 1-3
       Failed 3/3 tests, 0.00% okay
t/jpeg/read.......dubious
       Test returned status 0 (wstat 139, 0x8b)
DIED. FAILED tests 1-2
       Failed 2/2 tests, 0.00% okay
t/jpeg/write......dubious
       Test returned status 0 (wstat 139, 0x8b)
DIED. FAILED tests 1-2
       Failed 2/2 tests, 0.00% okay
t/montage.........dubious
       Test returned status 0 (wstat 139, 0x8b)
DIED. FAILED tests 1-19
       Failed 19/19 tests, 0.00% okay
t/png/read-16.....dubious
       Test returned status 0 (wstat 139, 0x8b)
DIED. FAILED tests 1-5
       Failed 5/5 tests, 0.00% okay
t/png/read........dubious
       Test returned status 0 (wstat 139, 0x8b)
DIED. FAILED tests 1-6
       Failed 6/6 tests, 0.00% okay
t/png/write-16....dubious
       Test returned status 0 (wstat 139, 0x8b)
DIED. FAILED tests 1-5
       Failed 5/5 tests, 0.00% okay
t/png/write.......dubious
       Test returned status 0 (wstat 139, 0x8b)
DIED. FAILED tests 1-6
       Failed 6/6 tests, 0.00% okay
t/read............dubious
       Test returned status 0 (wstat 139, 0x8b)
DIED. FAILED tests 1-47
       Failed 47/47 tests, 0.00% okay
t/setattribute....dubious
       Test returned status 0 (wstat 139, 0x8b)
DIED. FAILED tests 1-71
       Failed 71/71 tests, 0.00% okay
t/tiff/read.......dubious
       Test returned status 0 (wstat 139, 0x8b)
DIED. FAILED tests 1-16
       Failed 16/16 tests, 0.00% okay
t/tiff/write......dubious
       Test returned status 0 (wstat 139, 0x8b)
DIED. FAILED tests 1-10
       Failed 10/10 tests, 0.00% okay
t/wmf/read........dubious
       Test returned status 0 (wstat 139, 0x8b)
DIED. FAILED tests 1-2
       Failed 2/2 tests, 0.00% okay
t/write...........dubious
       Test returned status 0 (wstat 139, 0x8b)
DIED. FAILED tests 1-32
       Failed 32/32 tests, 0.00% okay
t/zlib/read.......dubious
       Test returned status 0 (wstat 139, 0x8b)
DIED. FAILED test 1
       Failed 1/1 tests, 0.00% okay
t/zlib/write......dubious
       Test returned status 0 (wstat 139, 0x8b)
DIED. FAILED test 1
       Failed 1/1 tests, 0.00% okay
Failed Test      Stat Wstat Total Fail  Failed  List of Failed
-------------------------------------------------------------------------------
t/blob.t            0   139     1    2 200.00%  1
t/bzlib/read.t      0   139     1    2 200.00%  1
t/bzlib/write.t     0   139     1    2 200.00%  1
t/composite.t       0   139    18   36 200.00%  1-18
t/filter.t          0   139    58  116 200.00%  1-58
t/fpx/read.t        0   139     5   10 200.00%  1-5
t/fpx/write.t       0   139     4    8 200.00%  1-4
t/getattribute.t    0   139    25   50 200.00%  1-25
t/jbig/read.t       0   139     1    2 200.00%  1
t/jbig/write.t      0   139     1    2 200.00%  1
t/jp2/read.t        0   139     3    6 200.00%  1-3
t/jpeg/read.t       0   139     2    4 200.00%  1-2
t/jpeg/write.t      0   139     2    4 200.00%  1-2
t/montage.t         0   139    19   38 200.00%  1-19
t/png/read-16.t     0   139     5   10 200.00%  1-5
t/png/read.t        0   139     6   12 200.00%  1-6
t/png/write-16.t    0   139     5   10 200.00%  1-5
t/png/write.t       0   139     6   12 200.00%  1-6
t/read.t            0   139    47   94 200.00%  1-47
t/setattribute.t    0   139    71  142 200.00%  1-71
t/tiff/read.t       0   139    16   32 200.00%  1-16
t/tiff/write.t      0   139    10   20 200.00%  1-10
t/wmf/read.t        0   139     2    4 200.00%  1-2
t/write.t           0   139    32   64 200.00%  1-32
t/zlib/read.t       0   139     1    2 200.00%  1
t/zlib/write.t      0   139     1    2 200.00%  1
Failed 26/26 test scripts, 0.00% okay. 343/343 subtests failed, 0.00% okay.
*** Error code 255

Stop in /usr/ports/graphics/ImageMagick/work/ImageMagick-6.4.1/PerlMagick.
*** Error code 1

Stop in /usr/ports/graphics/ImageMagick/work/ImageMagick-6.4.1.
*** Error code 1

Stop in /usr/ports/graphics/ImageMagick/work/ImageMagick-6.4.1.
*** Error code 1

Stop in /usr/ports/graphics/ImageMagick/work/ImageMagick-6.4.1.
*** Error code 1

Stop in /usr/ports/graphics/ImageMagick.
*** Error code 1

Stop in /usr/ports/graphics/ImageMagick.
#


my ImageMagick configuration:


# cd /usr/ports/graphics/ImageMagick/
# make showconfig
===> The following configuration options are available for ImageMagick-6.4.1.5:
    X11=on "X11 support"
    IMAGEMAGICK_TESTS=on "Run bundled self-tests after build"
    IMAGEMAGICK_OPENMP=off "Enable OpenMP for SMP"
    IMAGEMAGICK_PERL=on "Perl support"
    IMAGEMAGICK_MODULES=off "Modules support (broken)"
    IMAGEMAGICK_BZLIB=on "Bzlib support"
    IMAGEMAGICK_16BIT_PIXEL=on "16bit pixel support"
    IMAGEMAGICK_DJVU=off "DJVU format support (needs threads)"
    IMAGEMAGICK_LCMS=on "LCMS support"
    IMAGEMAGICK_HDRI=off "High Dynamic Range Images (HDRI)"
    IMAGEMAGICK_TTF=on "Freetype support"
    IMAGEMAGICK_FONTCONFIG=on "Fontconfig support"
    IMAGEMAGICK_JPEG=on "JPG format support"
    IMAGEMAGICK_OPENEXR=off "OpenEXR support (needs threads)"
    IMAGEMAGICK_PNG=on "PNG format support"
    IMAGEMAGICK_TIFF=on "TIFF format support"
    IMAGEMAGICK_FPX=on "FPX format support"
    IMAGEMAGICK_JBIG=on "JBIG format support"
    IMAGEMAGICK_JPEG2000=on "JPEG2000 format support"
    IMAGEMAGICK_DOT=on "GraphViz dot graphs support"
    IMAGEMAGICK_WMF=on "WMF format support"
    IMAGEMAGICK_SVG=on "SVG format support"
    IMAGEMAGICK_PDF=on "PDF format support"
    IMAGEMAGICK_GSLIB=on "libgs (Postscript SHLIB) support"
===> Use 'make config' to modify these settings
#

It builds for me, tested with your config, maybe update ports and try again? Otherwise what does portmanager -s tell you?


Chris

I reinstalled all ports on which ImageMagick depends and
built a newer version of IM - 6.4.1.8, still the same resut.

I use portmaster, so what does portmanager -s do?

Tells you port status, what needs to be updated because it's old, what
needs to be updated because a dependency is old. I haven't used
portmaster but I imagine you can make it do the same, might be worth a
different utilities opinion though. It's safe to run, it doesn't change
anything. Redirect the output to a file though.


Also do you know what does the last option do:
        IMAGEMAGICK_GSLIB=on "libgs (Postscript SHLIB) support"

it is "off" by default. I think I'll try to rebuild with the
default settings.

Sorry don't know this.

This url http://archive.netbsd.se/?ml=freebsd-ports&a=2007-09&t=5280057
is worth a read in case you haven't already found it.

Chris


many thanks
anton



_______________________________________________
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to