On Friday, February 14, 2003, at 11:21 AM, stan wrote:

On Thu, Feb 13, 2003 at 11:46:47AM -0800, Mark Edwards wrote:
On Thursday, February 13, 2003, at 11:29 AM, Joe Marcus Clarke wrote:

On Thu, 2003-02-13 at 13:03, Mark Edwards wrote:
I've fixed my XFree86 install, and I have 4.2.1 running. All of the
ports mentioned above are installed. I am able to run xf86cfg
graphically and configure, and I can run X using startx, which loads

However, when I do:

sudo /usr/X11R6/etc/rc.d/gdm.sh start

I get:

Feb 13 01:28:56 lilbuddy gdm[15381]: Failed to start the display
several times in a short time period; disabling display :0
I would need to see the X log to know if it's a gdm problem.
I've never tried starting gdm under sudo.
Well, the same behavior occurs if I just restart the machine and let
the script be triggered normally, so I doubt that sudo has anything to
do with it. Also, I successfully started gdm many times this way
gnome 2.0.

I have posted /var/log/:0.log and var/log/XFree86.0.log here:

Nothing useful here.  You might try doing a forced rebuild of gdm2.

I got it.  I tried switching to root, and running startx (root's
.xinitrc was set to start gnome).  I got a complaint that fontconfig
couldn't start.  Aha!

I removed /usr/X11R6/etc/fonts and reinstalled
/usr/ports/x11-fonts/fontconfig and voila!  Everything's fine, AND I
have anti-aliased fonts!  Damn, that was painful, but I guess it was
worth it.
I"m fighting this exact same problem, and I was wondering if I could
trouble you with a couple of questions.

You say you removed /usr/X11R6/etc/fonts. Do you mean the whole thing? As
in evert font on the system? If so, exactly what did you do to reinstall
just the fonts?
My /usr/X11R6/etc/fonts directory looks like this:

total 16
-r--r--r-- 1 root wheel 8618 Feb 13 11:35 fonts.conf
-r--r--r-- 1 root wheel 5712 Feb 13 11:35 fonts.dtd

So, I removed that directory, and I did

cd /usr/ports/x11-fonts/fontconfig
make deinstall
make clean install

That fixed the problem for me. I don't know that deleting the fonts.conf and fonts.dtd actually did anything, I was just shooting in the dark. I saw that something was foul with fontconfig, so I wanted to make sure I wiped out anything corrupted in fonts.conf. I knew the installer would replace that directory.

If two of us have had this issue now, I wonder if there's something about the build order of the gnome2.2 port that is messing up fontconfig when upgrading from a previous gnome2 install, or something like that. Does that sound plausible Joe?

Mark Edwards
Mr. Toad's
San Francisco, CA

To Unsubscribe: send mail to [EMAIL PROTECTED]
with "unsubscribe freebsd-questions" in the body of the message

Reply via email to