On Thursday, February 13, 2003, at 11:29 AM, Joe Marcus Clarke wrote:

On Thu, 2003-02-13 at 13:03, Mark Edwards wrote:
I've fixed my XFree86 install, and I have 4.2.1 running.  All of the
ports mentioned above are installed.  I am able to run xf86cfg
graphically and configure, and I can run X using startx, which loads

However, when I do:

sudo /usr/X11R6/etc/rc.d/gdm.sh start

I get:

Feb 13 01:28:56 lilbuddy gdm[15381]: Failed to start the display
several times in a short time period; disabling display :0
I would need to see the X log to know if it's a gdm problem. However,
I've never tried starting gdm under sudo.
Well, the same behavior occurs if I just restart the machine and let
the script be triggered normally, so I doubt that sudo has anything to
do with it. Also, I successfully started gdm many times this way under
gnome 2.0.

I have posted /var/log/:0.log and var/log/XFree86.0.log here:

Nothing useful here.  You might try doing a forced rebuild of gdm2.

I got it. I tried switching to root, and running startx (root's .xinitrc was set to start gnome). I got a complaint that fontconfig couldn't start. Aha!

I removed /usr/X11R6/etc/fonts and reinstalled /usr/ports/x11-fonts/fontconfig and voila! Everything's fine, AND I have anti-aliased fonts! Damn, that was painful, but I guess it was worth it.

I'm not sure what was fubar'd with fontconfig, but maybe make a mental note of it in case someone else is upgrading to gnome2.2 and gnome suddenly stops working. Could have simply been corruption on my end because of running a funky XFree86 3.3.6/gnome2 setup or something. I don't know and at this point I don't care, cause it works!

Thanks for your patience, Joe...

Mark Edwards
San Francisco, CA

To Unsubscribe: send mail to [EMAIL PROTECTED]
with "unsubscribe freebsd-questions" in the body of the message

Reply via email to