> the output is: "amd64"
> When I run: "sysctl -a | less"
> and search for: "CPU"
> I see that:
> "hw.model: Intel(R) Xeon(R) CPU            5140  @ 2.33GHz
> ...
> hw.machine_arch: amd64"

I know it's slightly off topic, but when comes the time to verify
hardware details, then you might want to take a look at dmidecode(8).
It's available in the FreeBSD ports as sysutils/dmidecode or from it's
website at http://www.nongnu.org/dmidecode/

This tool enables you to retrieve things like bios-vendor,
bios-version,  bios-release-date,  system-manufacturer,
system-product-name, system-version, system-serial-number,
system-uuid, baseboard-manufacturer,  baseboard-product-name,
baseboard-version, baseboard-serial-number, baseboard-asset-tag,
chassis-manufacturer, chassis-type, chassis-version,
chassis-serial-number, chassis-asset-tag, processor-family,
processor-manufacturer, processor-version,  processor-frequency, etc.

It's also available for other UNIX flavors too, so it's nice when you
have a heterogeneous environment where sysctl and uname don't have the
exact same flags. I've tried it successfully on various versions of
FreeBSD, RedHat Enterprise Linux & Ubuntu Linux.


David Robillard
UNIX systems administrator & Oracle DBA
CISSP, RHCE & Sun Certified Security Administrator
Montreal: +1 514 966 0122

If you receive something that says "Send this to everyone you know",
then please pretend you don't know me.
freebsd-questions@freebsd.org mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to