Gene Harris wrote:

This is usually an xhost problem, where a local machine is not letting a remote machine spawn a window. If you have entered the command

xhost +127.0.0.1 (or xhost +localhost)

and you still get this problem, then there may be an issue with your tcp ip setup. You may want to find any X*.hosts files and make sure they contain the correct host names (you can also delete them and use xhost to recreate them). You also need to ping 127.0.0.1 and make sure you get something back. I had this problem once, because my firewall was not allowing the loopback interface to function correctly.

If you are using startx to initiate your X-windows session, try starting it with startx -listen_tcp and then reenter your xhost commands for local host. If you are using xdm (or something else) to start X for you, then make sure X is listening on a tcp port by checking the output of sockstat.

Good luck. I am off to breakfast on a cold, gray winter's day in Oklahoma. I hope it is nicer in the Netherlands that it is here.

Gene

On Sunday 16 February 2003 08:48 am, Dennis wrote:

Gene Harris wrote:

What is the exact error message you receive after you 'su -m' and then try
to execute your program?

All that a non-standard shell means is that it is not listed in
/etc/shells.

Gene

hmm i see...

this is the error msg

Xlib: connection to ":0.0" refused by server
Xlib: No protocol specified
Gtk-WARNING **: cannot open display: :0.0

Dennis



It works!!

I used startx -listen_tcp, then added 127.0.0.1 with xhost, and the problem is solved!!

Thanx to ur effort.... Really appreciate it man...

Now i can waste time on irc again :)

Greetz D.



To Unsubscribe: send mail to [EMAIL PROTECTED]
with "unsubscribe freebsd-questions" in the body of the message


Reply via email to