Wow, a sympathetic ear, was expecting far more scorn than that :-)

I am currently running TestDisk, which at least _appears_ to be finding something filesystem-like (at least it's listed a few "empty" "somethings" that look somehow reasonable, size-wise.) Cross your fingers. Gpart and TestDisk are entirely passive, i.e. don't touch data on the disks.

My plan, if this works out, is to buy a secondary backup consisting of a RAID 1+0 NAS. I don't have anything big enough to back up everything to.

I tried pretty much everything with fsck_ufs. Like I said, though, I am able to mount the entire partition from the bootable IDE drive. I see /, /etc/, /dev/ and all that, but since the "rescue" OS can't see any additional superblocks, it has no devices for the other filesystems. I am not sufficiently well versed in UFS to understand how an entire partition can be mounted as a filesystem if that partition originally had multiple filesystems on it. I'm a bit wary of playing more with fsck until all else has failed. :-)

What also weirds me out is that FreeBSD constantly bitches about the partition being larger than the physical disk (which it decidedly isn't.) I've tried setting geometry in fdisk any which way (including using the RAID controller's provided values), and as I said, the thing mounts the root partition of the array just fine. I'm considering an exorcist.



On Jul 21, 2008, at 12:52 PM, Polytropon wrote:


On Mon, 21 Jul 2008 11:57:09 +0200 (CEST), "John Morgan Salomon" <[EMAIL PROTECTED] > wrote:
Before you ask, this was the backup server. My primary box had decided to
die shortly before.  I had no backup backup server.  Murphy strikes.

I completely do understand you, I'm suffering from a similar problem
at the moment, but much worse than yours...

Buy tape drives! Buy tape drives! Buy tape drives! :-)

Can someone recommend a way to manually scan the entire partition (either aacd0, aacd0s1 or aacd0s1c) for formerly present filesystems? I am 99%
sure that all the data is still present, and if I reinstall the
superblocks I'll be able to boot the array, mount the filesystems and get
the data off before I continue.  I don't know whether I've missed any
gpart options (I have the impression it only scans for lost partitions,
not ufs filesystem signatures.)

As far as I know - NB that I'm just starting to learn more about UFS,
shame on me that I'll do this just as every piece of data is gone -
there are more than one superblock present. According to "man fsck_ufs",
this could be a starting point:

-b Use the block specified immediately after the flag as the super block for the file system. An alternate super block is usually
            located at block 32 for UFS1, and block 160 for UFS2.

This applies if just the first superblock is gone.

Before you start experimenting, maybe it's a good idea to dd the
data out of the disks and run fsck on the images? I'm not sure...

Any help, tips or pointers would be tremendously appreciated.

Hope you're lucky.

From Magdeburg, Germany
Happy FreeBSD user since 4.0
_______________________________________________ mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED] "

_______________________________________________ mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to