I have 2 mem sticks and several CF cards from a Nikon Coolpix camera.
In the past I've freely used these both ways, through USB.
My OS is, via uname -a:

FreeBSD daisy.local 7.0-RELEASE FreeBSD 7.0-RELEASE #0: Sun Feb 24 10:35:36 UTC 2008 [EMAIL PROTECTED]:/usr/obj/usr/src/sys/GENERIC amd64

I had a problem with a new 4GB CF card which wouldn't mount in an
audio recorder (M-Audio Microtrack), and tried formatting it using the
recorder's own formatter.  OK so far.  But it wouldn't mount on my
FreeBSD.  So I perhaps unwisely tried working from scratch, rebuilding
the MBR (copied from /boot/mbr) and using fdisk from there.

Now I can mount it and all the other (photo) CF cards, but xv(1) for
the first time complains of *.jpg saying: <filename>: "Corrupt JPEG
data: premature end of data segment" and quits.

At one time I guessed perhaps badly that I should use fdisk with powers
of two and rebuild a CF card with 64 heads and 32 sectors; let the #cyls
fall out.  Looks good, but now fdisk on all my USB CF cards says those
are the numbers unless I use fdisk -i -t.

Yet I can reboot.  When I do, CF cards still mount and are still not
viewable with xv.  something strange has happened and I wonder if some
persistent data regarding msdosfs structures has been written.

I had hoped that #cyl, #head, #sec values would be ignored in favor of
LBA, but I guess I'm wrong.

Any ideas?
        Chuck Bacon -- [EMAIL PROTECTED]
freebsd-questions@freebsd.org mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to