vardyh wrote:
Matthew Seaman wrote:
vardyh wrote:
Hi all.
I'm a newbie to FreeBSD. I added
to /boot/loader.conf and I got
   'hptrr: no controller detected.'
on the next boot. I didn't change anything else except for the 'console=xxx'.
And I had had no problem before that. Could anyone tell me why?
I will very appreciate for your help :>

This is just the driver for the HighPoint Rocket Raid controller being
a bit too verbose.  It's detected that you don't have anything compatible
with hptrr(4) and (unlike the usual behaviour of most Raid Controller
drivers (or drivers for any sort of hardware really)) it considers this fact to be of such vital importance that it really had to print out something on the console. Needless to say such behaviour has already been quashed in 7-STABLE and will not appear in 7.1-RELEASE.

In other words, it's harmless and you can just ignore it. I suspect that this output wasn't actually triggered by your changing
the console setting -- there's no conceivable way changing one should
affect the other -- but that changing the way the boot messages are displayed has managed to draw your attention to it. You probably had it before but never noticed.

But, actually it claimed that no controller detected and asked me to
specify the root filesystem manually, which wrote:

Trying to mount root from ufs:/dev/ad0s1a
Manul root filesystem specification:
 <fstype>:<device> Mount <device> using filesystem <fstype>
                                    eg. ufs:da0s1a
 ?                              List valid disk boot devices
 <empty line>           Abort manual input

I tried ufs:/dev/ad0s1a, which was the real root filesystem registered
in my /etc/fstab, but it still could not be mounted. And the same
direction came out again to asked me to point out the root fs.

I tried '?' also, but it seems that no disk devices were found... The
kernel told me "List of GEOM managed disk devices:", and nothing but the
same old direction followed.

Ah.  This is a different problem, unrelated to the 'no controller
detected' message.  Unless you actually /do/ have a controller driven
by hptrr(4)?

Basically your problem is that /dev/ad0 has disappeared -- and as that's
where the boot code expected to mount the root filesystem from, it
threw a big spanner in the works.

Now, ad0 can disappear for a number of reasons:

   * the disk has died

   * the disk was unplugged and then not plugged back in again

   * the disk was plugged into a different connector internally
     (it could appear as one of ad1, ad2 or ad3 in this case)

   * you changed some BIOS settings and now the system is presenting
     the disk as a SATA device (it could appear as ad4 or ad6 in
     this case)

   * you changed some BIOS settings and now the system has tried to
     generate some sort of RAID from the attached drives -- this could
     appear as ar0, or it could prevent FreeBSD seeing the drive(s) at
all or it could have just shredded the contents of your disk and left you up a gum tree. (Normally you would have had to click through several dire warning messages in the last case, so this eventuality shouldn't have been particularly surprising to you)

Check all the connectors.  Check the disk is properly seated, especially
if it's a hotswap device. Try booting up the installation media or a Freesbie disk or any sort of LiveCD and see what hardware the kernel discovers at boot time. If you have been changing BIOS settings, try changing them back to what they were originally.


Dr Matthew J Seaman MA, D.Phil.                   7 Priory Courtyard
                                                 Flat 3
PGP:     Ramsgate
                                                 Kent, CT11 9PW

Attachment: signature.asc
Description: OpenPGP digital signature

Reply via email to