I have tried doing the forwarding via /etc/mail/aliases and it worked
identically as it was with the /root/.forward. The mail does go through but
gets delayed 5+ minutes, however when I send mail interactively using mailx
or mail commands the receiving mailserver receives the message instantly.

I'd also like to add that if I restart sendmail via /etc/rc.d/sendmail
restart the mail gets instantly received also...Thanks for the help thus far

On Fri, Aug 15, 2008 at 6:22 PM, Derek Ragona <
[EMAIL PROTECTED]> wrote:

>  At 03:49 PM 8/15/2008, Tom Stuart wrote:
>
> I've been having trouble sending email that was sent via a process(swatch).
> I can send emails fine via command-line and receive immediately to the
> forwarded address. However when sent via swatch it can take 5-10 minutes.
> These entries appear in /var/log/mailllog. Note this is all relating to the
> same email and notice the 11 minute delay. Thanks in advance for any help.
>
> Aug 15 14:35:12 firewall-1 sendmail[72747]: m7FKZCXf072747: from=username,
> size=155, class=0, nrcpts=1, msgid=<
> [EMAIL PROTECTED]>, [EMAIL PROTECTED]
> ocalhost
> Aug 15 14:35:12 firewall-1 sendmail[72747]: m7FKZCXf072747: to=root,
> delay=00:00:00, mailer=relay, pri=30155, stat=queued
> Aug 15 14:43:18 firewall-1 sendmail[72762]: m7FKhHx8072762: from=username,
> size=0, class=0, nrcpts=0, [EMAIL PROTECTED]
> Aug 15 14:46:03 firewall-1 sm-mta[72794]: m7FKk3wc072794: from=<
> [EMAIL PROTECTED]>, size=512, class=0, nrcpts=1, msgid=<
> [EMAIL PROTECTED]>, proto=ESMTP,
> daemon=Daemon0, relay=localhost [127.0.0.1]
> Aug 15 14:46:03 firewall-1 sm-msp-queue[72793]: m7FKZCXf072747: to=root,
> ctladdr=username (1001/1001), delay=00:10:51, xdelay=00:00:00,
> mailer=relay,
> pri=120155, relay=[127.0.0.1
> ] [127.0.0.1], dsn=2.0.0, stat=Sent (m7FKk3wc072794 Message accepted for
> delivery)
> Aug 15 14:46:03 firewall-1 sm-mta[72795]: m7FKk3wc072794: to=
> [EMAIL PROTECTED], ctladdr=<[EMAIL PROTECTED]> (1001/1001),
> delay=00:00:00, xdelay=00:0
> 0:00, mailer=relay, pri=30809, relay=smtp.xxx.com. [10.0.0.2], dsn=2.0.0,
> stat=Sent ( <[EMAIL PROTECTED]> Queued mail
> for
> delivery)
>
>
> I think its important to know these details:
> firewall-1# uname -a
> FreeBSD firewall-1.xxx.com 7.0-RC1 FreeBSD 7.0-RC1 #2: Tue Feb  5 07:10:05
> MST 2008     [EMAIL PROTECTED]:/usr/obj/usr/src/sys/FIREWALL-1  i386
>
> There is a .forward file in /root to forward root's mail to
> [EMAIL PROTECTED] is to be sent via smarthost.
>
> I have the smarthost "DS" parameter in /etc/mail/sendmail.cf configured to
> use DSsmtp.xxx.com
>
> /etc/hosts contains
> localhost             127.0.0.1 firewall-1 firewall-1.xxx.com
> smtp.xxx.com     10.0.0.2
>
>
> Have you tried changing the alias for root to the forwarded address in
> /etc/mail/aliases?  You can make the change there and rebuild the aliases
> file.
>
>         -Derek
>
> --
> This message has been scanned for viruses and
> dangerous content by *MailScanner* <http://www.mailscanner.info/>, and is
> believed to be clean.
_______________________________________________
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to