Hello,

I've got the last java jdk 1.6 (diablo version) from freebsd
foundation and when I tried to install the tomcat 6 from the ports I
had
some problems. The tomcat 6 port* tries to find the java binaries in
the /usr/local/jdk1.5.0. Please see the output below.

duamutef# make install clean
===>  Cleaning for apache-tomcat-6.0.16
===>  Vulnerability check disabled, database not found
===>  Extracting for apache-tomcat-6.0.16
=> MD5 Checksum OK for apache-tomcat-6.0.16.tar.gz.
=> SHA256 Checksum OK for apache-tomcat-6.0.16.tar.gz.
===>  Patching for apache-tomcat-6.0.16
Installation settings:
   Destination directory:    /usr/local/apache-tomcat6.0
   Location of JDK:          /usr/local/jdk1.5.0
   Location of Java port:    java/jdk15
   Running as (user/group):  www/www
   HTTP port:                8180
   Shutdown listener port:   8005
   AJP 1.3 connector port:   8009
   Logfile stdout:           /usr/local/apache-tomcat6.0/logs/stdout.log
   Logfile stderr:           /usr/local/apache-tomcat6.0/logs/stderr.log
===>  Applying FreeBSD patches for apache-tomcat-6.0.16
>> Removing unneeded files... [ DONE ]
>> Customizing server.xml... [ DONE ]
===>  Configuring for apache-tomcat-6.0.16
===>  Installing for apache-tomcat-6.0.16
===>   apache-tomcat-6.0.16 depends on file:
/usr/local/jdk1.5.0/bin/java - not found
===>    Verifying install for /usr/local/jdk1.5.0/bin/java in
/usr/ports/java/jdk15
===>  jdk-1.5.0.14p8_3,1 :
 Due to licensing restrictions, certain files must be fetched manually.

 Please open http://download.java.net/tiger/archive/tiger_u14/
 in a web browser.  Download the
 Update 14 Source, jdk-1_5_0_14-fcs-src-b03-jrl-05_oct_2007.jar and the
 Source Binaries, jdk-1_5_0_14-fcs-bin-b03-jrl-05_oct_2007.jar .

 Please open http://java.sun.com/javase/downloads/index.jsp
 in a web browser and follow the "Download" link for
 "JDK US DST Timezone Update Tool - 1_3_6" to obtain the
 time zone update file, tzupdater-1_3_6-2008c.zip.

 Please download the patchset, bsd-jdk15-patches-8.tar.bz2, from
 http://www.eyesbeyond.com/freebsddom/java/jdk15.html.

 Please place the downloaded file(s) in /usr/ports/distfiles
 and restart the build.

.*** Error code 1

Stop in /usr/cvsup/current/ports/java/jdk15.
*** Error code 1

Stop in /usr/cvsup/current/ports/www/tomcat6.


Since I'm using the diablo-jdk1.6 that is located in
/usr/local/diablo-jdk1.6.0, it doesn't work. I tried to find some
variable to set where is my jdk, but no lucky.


I tried the following and it worked well.

cd /usr/local/ ; ln -s diablo-jdk1.6.0 jdk1.5.0

But creating a symbolic link from jdk1.5 to jdk1.6 seems not to be the
best way. Is there a better way to install tomcat 6 *from the ports*
using diablo-jdk1.6?

Thank you.
_______________________________________________
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to