On Wednesday 17 September 2008 05:17:27 pm John Baldwin wrote:
> On Wednesday 17 September 2008 11:00:24 am Scott Gasch wrote:
> > You're right: atapci1, atapci2, fwohci0 and uhci4 are all sharing the same
> > irq (19) while irqs 20, 21, 22 at least seem completely unused.  Here's a
> > dumb question: how do I fix it?  I tried setting "plug and play OS" in the
> > BIOS and then using device.hints to push different devices to different
> > irqs.  But every time I tried a new hint it seemed to be ignored.  I was
> > trying stuff like:
> > 
> > set hint.atapci.1.irq="20"
> > set hint ata.4.irq="20" (ata4 is a channel on atapci1)
> > set hint fwhco.0.irq="20"
> > etc...
> > 
> > 
> > I also tried to move the dc driver to a new irq as a test.  This was also
> > seemingly ignored.
> > 
> > I then tried turning "plug and play OS" off in the BIOS but I don't see
> > anywhere to set the IRQs of the onboard SATA controllers via the menus.  
> > looking for a BIOS upgrade now... any other advice?
> Unfortunately you can't really move PCI IRQs around.  You can read about 
> of the gritty details here: 
> http://people.freebsd.org/~jhb/papers/bsdcan/2007/
> You might be able to shuffle some IRQs around using 'hw.pciX.Y.INTA.irq' 
> tunables.

Gah, wrong tunables.  These devices are on PCI link devices, so you'd need to 
do something like 'hw.pci.LNKA.irq' (where LNKA is the name of the link 
device in the ACPI namespace).  Verbose boot messages (boot -v) can tell you 
which link device you PCI devices are using.

John Baldwin
freebsd-questions@freebsd.org mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to