Thanks Bob.

I did a bit more reading, and it seems that I can turn on additional sentences in the driver. Ive been studying the NMEA output and there are two sentences which will give time figures across two subsequent seconds, so I tried enabling those ("mode 6" in the server statement), but still no dice. I can see all of the correct sentences being picked up in ntpq using the "clocklist" command, but it just doesnt seem to want to work. Essentially my GPS reference just sits like this:

building# ntpq -p
remote refid st t when poll reach delay offset jitter = = = = = = ======================================================================== resolv.internod 2 u 72 256 17 19.343 36.263 37.083 2 u 64 256 17 24.882 0.279 18.807 GPS_NMEA(0) .GPS. 0 l - 64 0 0.000 0.000 4000.00

Which I assume means "nope, not working".

Is PPS absolutely neccessary? The GPS12 doesnt have PPS, so perhaps this is my issue? The output of NMEA seems to happen every 1.5 seconds, but there are 3 sentences which output a time figure, so I figured I'd enable the two furthest apart in the hope that they may coincide with different seconds, and hopefully ntpd would be able to work it out from that. I even tried enabling all 3 of them ("mode 7"), but still nothing.

Anyway, Im looking at grabbing a Garmin GPS18 LVC, they are only just over $100 so no biggie. People have reported wide success with this device, so I think I'll still with what is known to work and go from there.


On 20/09/2008, at 8:09 AM, Bob Johnson wrote:

On 9/19/08, Tom Storey <[EMAIL PROTECTED]> wrote:
Hi all,

Ive been toying with setting up my old Garmin GPS12 as a reference for a
server (FreeBSD 6.2) running ntpd, but Ive run into an issue.

Is it possible the issue isn't what you think it is?

Ive searched around a bit and cant find an answer, perhaps because there
isnt one.

I once (years ago) had a Garmin GPS working with ntpd, so it's
reasonable to believe it can be done again, unless support for that
capability was dropped (which I doubt). Unfortunately, it was long
enough ago that I don't remember what I did. It's possible I used the
1 PPS output without NMEA sentences, but that's not my recollection.

Is there any way I can set ntpd to expect a $GPRMC string every 2 seconds,
which is the frequency at which the GPS12 transmits them?

Alternatively, does anyone know how to make the GPS12 transmit a $GPRMC
string every second?

I'm almost certain you can't. The complete set of all NMEA sentences
takes more than one second at the default 4800 baud, so IIRC it
outputs sentences only on odd seconds, and perhaps the older units are
too slow to compute a fix once per second. Two things that may work
around this are to turn off everything except the GPRMC sentence:


and perhaps free up some CPU time (for faster position calculation) by
(oddly enough) reducing the output data rate to 1200 bps:


but I don't think that will actually work. To go back to 4800 bps, use
3 instead of 1. I think there are 11 commas after the "C" in that
command, but my eyes aren't so sharp any more.

There is a Linux driver for the Garmin proprietary protocol. Don't
know if it is distributed in a FreeBSD version. Try

If there is a better place I can post this, please let me know.

This is probably a good place for this question, but if you don't get
a better answer, try the archives of the "time nuts" mailing list which
unfortunately appears to be down right now. General info about that
group is at

If that yields nothing, you might post your question to the Time Nuts
list, time-nuts @ It is probably a FAQ for them, but they
will be polite about it. And I had hoped to once again stick an old
Garmin on an NTP server, so I'll be curious to know if this turns out
to be insurmountable.

Good luck,

-- Bob Johnson

_______________________________________________ mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to