I wonder if this is the right place to ask a question regarding FreeBsd7
and the Handbook.

I have installed FreeBsd7 both i386 and amd64 architectures in two
macines, one celeron dual core with 1GB, the other amd64x2 3800+ ,and I
have problem with my scanner.

I repeat here my thread to DaemonForums-BSD forum, which is self
expanatory. Please bear in mind that I am new to computing and know a
little bit only about Linux. I have not used any other operating system.

Here it is:

hello everybody,

I am a computer newby, learning Linux and started with FreeBSD lately.
The only OSs I know about.

I am struggling with FreeBSD7 both as an i386 and amd64 architecture.

The problem is my scanner a Canon Lide 60. Running #scanimage -L I get
"device `genesys:libusb:/dev/usb1:/dev/ugen0' is a Canon Lide 60 flatbed
scanner" which is right and it shows up with xsane as root (when I am
lucky to use xsane as root in gnome)

Now trying to: "7.6.4 Giving Other Users Access to the Scanner

All previous operations have been done with root privileges. You may
however, need other users to have access to the scanner. The user will
need read and write permissions to the device node used by the scanner.
As an example, our USB scanner uses the device node /dev/uscanner0 which
is owned by the operator group. Adding the user joe to the operator
group will allow him to use the scanner:

# pw groupmod operator -m joe

For more details read the pw(8) manual page. You also have to set the
correct write permissions (0660 or 0664) on the /dev/uscanner0 device
node, by default the operator group can only read the device node. This
is done by adding the following lines to the /etc/devfs.rules file:

add path uscanner0 mode 660

Then add the following to /etc/rc.conf and reboot the machine:


More information regarding these lines can be found in the devfs(8)
manual page.

Note: Of course, for security reasons, you should think twice before
adding a user to any group, especially the operator group."

I cannot find "/etc/devfs.rules" file, it does not exist. I tried to
make one adding what I was instructed, to no avail. I tried to put
"[system=5]" etc in the "/etc/defaults/devfs.rules" file, which exists,
but it did not work either.

I suppose I must be doing something wrong. Please bear in mind that this
is my first time that I am using the command line. I have been able to
thanks to the very easy and instructive FreeBSD's handbook.

If you know why "/etc/devfs.rules" file is missing from both i386 and
amd64 installations and what I can do if anything, please inform me.

Thank you very much for your efort,

Edit/Delete Message

If this is the wrong place to ask please correct me.

Thank you,

John Vliouras
freebsd-questions@freebsd.org mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to