On Thu Oct 2 06:59:47 UTC 2008 Jonathan McKeown wrote:
On a system running 6.2-RELEASE, with a 6.2-RELEASE Disc 1 in the CD drive but not mounted:

mkdir serialcd

tar xvfC /dev/acd0 serialcd

These two commands created a directory tree in serialcd containing most of the contents of the CD. There was a ``tar ignoring out-of-order file'' error, and when I mounted the CD and ran

diff -qr  /cdrom serialcd

it reported that RELNOTES.TXT differed - in fact the version in the serialcd directory turned out to have zero length. [I suspect you could probably do this comparison quicker with mtree, and I never did bother to fix it or find out why it was happening]

Thanks, Jonathan. So I've redone the process again. I'm working from the original ISO image instead of a physical CD copy of it, so I utilize step 4 from Jeremy Chadwick's document (http://jdc.parodius.com/freebsd/pxeboot_serial_install.html) to make the initial directory tree. There are no tar error messages.

I edited serialcd/boot/loader.conf to include the line


I did exactly that, although I also tried adding the following lines instead on a separate attempt:


I then ran

mkisofs -J -r -b boot/cdboot -no-emul-boot -o serialcd.iso serialcd

and got an ISO image, serial.iso, which is about 600MB.

Your switches are a little different from my original procedure, so this time I used yours.

The only drawback with this method is that the serial console only cuts in just before the boot menu. I suspect that if you wanted to have a serial console for every stage of the boot you would need to mess about with the ramdisk image on the CD.

So creating a boot.config in the root of the CD image cannot be used the way it is for a hard drive installation in order to solve that problem?

Anyway, I didn't create a boot.config this time, so I should have ended up with a 7.0 equivalent of your 6.2 serialcd.iso, which I then burned and tried. End result? Abject failure again. All boot stages still use the internal console.

Just after "Loading /boot/defaults/loader.conf" appears, there is a *very* long pause added as compared with the unmodified install CD. Eventually it resumes. Don't know why that's happening.

Carl                                             / K0802647
freebsd-questions@freebsd.org mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to