Hello,

I just installed KDE4 via ports and am getting errors upon attempting
to start as a "regular" user. When I run startkde as root it works
fine but I don't want to use root on this machine.

Error Generated when started as a regular user
$ startx
/libexec/ld-elf.so.1: Shared object "libXau.so.6" not found, required by "xauth"
/libexec/ld-elf.so.1: Shared object "libXau.so.6" not found, required by "xauth"
/libexec/ld-elf.so.1: Shared object "libXau.so.6" not found, required by "xauth"
/libexec/ld-elf.so.1: Shared object "libXau.so.6" not found, required by "xauth"
/libexec/ld-elf.so.1: Shared object "libXau.so.6" not found, required by "xauth"
/libexec/ld-elf.so.1: Shared object "libX11.so.6" not found, required by "xinit"
/libexec/ld-elf.so.1: Shared object "libXau.so.6" not found, required by "xauth"

The files are there
$ ls -l /usr/local/lib/libXau.so /usr/local/lib/libX11.so
lrwxr-xr-x  1 root  wheel  11 Oct  6 03:09 /usr/local/lib/libX11.so ->
libX11.so.6
lrwxr-xr-x  1 root  wheel  11 Oct  6 03:06 /usr/local/lib/libXau.so ->
libXau.so.6
$ ls -l /usr/local/lib/libXau.so.6 /usr/local/lib/libX11.so.6
-rwxr-xr-x  1 root  wheel  1080722 Oct  6 03:09 /usr/local/lib/libX11.so.6
-rwxr-xr-x  1 root  wheel    10604 Oct  6 03:06 /usr/local/lib/libXau.so.6

$ cat .xinitrc
exec /usr/local/kde4/bin/startkde

$ uname -a
FreeBSD xxx.xxx.net 7.1-PRERELEASE FreeBSD 7.1-PRERELEASE #2: Mon Oct
6 02:45:38 MDT 2008     [EMAIL PROTECTED]:/usr/obj/usr/src/sys/xxx
i386

I'm sure this is a very little issue but I appreciate your patience
and help in resolving this issue.

Best Regards,

Tom
_______________________________________________
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to