sh/bash: export FTP_PASSIVE_MODE=true
    csh: setenv FTP_PASSIVE_MODE true

First off, this did solve the problem. Thank you, Jeremy.

Now, as to the why...

That's odd, because if you are running  7.x with a default settings,
FTP_PASSIVE_MODE should be irrelevant to fetching distfiles - even if
it's set to "no".

Do you have any FETCH_* variables defined?


What happens if you cd to a
port directory and type: make -V FETCH_CMD ?

[EMAIL PROTECTED]:~]> cd /usr/ports/shells/zsh
/usr/bin/fetch -ApRr

I then wanted to install NTP:

cd /usr/ports/net/ntp
make config; make install clean

This failed because the mirrors were not accessible.

I just tried this port myself and it failed on all four servers
configured in the Makefile, only succeeding on the fallback Freebsd
server, (Freebsd's own cache for package building).

Unless you turn-up something odd for FETCH_CMD, I think there's
a good chance that you never had an FTP firewall problem in the first
place, and that the file has simply been added to since
you got the original failure.

I just removed the FTP_PASSIVE_MODE variable from .bash_profile, logged out, and logged back in. I then tried to install another port and it installed without problem.

-- John

_______________________________________________ mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to