On Tue, Oct 14, 2008 at 08:28:13PM +0200, Aniruddha wrote:
> I tried to change the root's shell to bash. I used this command: 'chsh
> -s /usr/local/bin/bash'. Prior to changing the shell for root I did it
> for my user account using the same command without problems.
> Unfortunately after a reboot I can't login as root anymore because my
> system can't find /usr/local/bin/bash.

I can't explain why your systems says it can't find /usr/local/bin/bash.
I would assume you also cannot log in as yourself.

You should not change root's shell.  I believe this has been discussed
many times in the past on lists -- you should use tools like sudo or su2
to change UIDs.  Both of those tools will allow you to take on root
credentials while using the shell of your user account (bash).

> How can I fix this? I tried booting the freesbie cd but this
> wouldn't boot :(. Thanks in  advance!

You'll need to boot your machine and at the FreeBSD boot menu, choose
option 4 for single-user mode.  You'll eventually be dropped into a
simple /bin/sh prompt.  You'll need to do "mount -a", then use "vipw" to
edit all of the fields in /etc/master.passwd -- specifically, change
root's shell back to /bin/csh.  Write the file, exit vipw, and reboot
the system.  You should be up and working after that.

| Jeremy Chadwick                                jdc at parodius.com |
| Parodius Networking                       http://www.parodius.com/ |
| UNIX Systems Administrator                  Mountain View, CA, USA |
| Making life hard for others since 1977.              PGP: 4BD6C0CB |

freebsd-questions@freebsd.org mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to