Hi folks,
After updating ports tree with portsnap fetch update, then running
pkg_version -l '<', pkg_version shows net-snmp is upgradable:

pkg_version -l '<'
net-snmp                            <

pkg_replace net-snmp
--->  Replacing 'net-snmp-5.3.2_3' with 'net-snmp-5.3.2.3'
--->  Building '/usr/ports/net-mgmt/net-snmp53'

You may use the following build options:

WITH_INETADDRESS_HACK=yes       builds with the inetaddress hack
WITH_TKMIB=yes          Install a graphical Perl/Tk/SNMP based mib browser
WITHOUT_DUMMY_VALUES=yes        Provide 'placeholder' dummy values where
                                the necessary information is not available.
WITHOUT_PERL=yes                Do not install the perl modules along
with the rest
                                of the net-snmp toolkit.
WITHOUT_IPV6=yes                Disable IPv6.

DEFAULT_SNMP_VERSION="3"        Default version of SNMP to use.
NET_SNMP_SYS_CONTACT="[EMAIL PROTECTED]"
                                Default system contact.
NET_SNMP_SYS_LOCATION="somewhere"
                                Default system location.
NET_SNMP_LOGFILE="/var/log/snmpd.log"
                                Default log file location for snmpd.
NET_SNMP_PERSISTENTDIR="/var/net-snmp"
                                Default directory for persistent data storage.
NET_SNMP_MIB_MODULES="host disman/event-mib smux mibII/mta_sendmail
mibII/tcpTable ucd-snmp/diskio"
                                Optional mib modules that can be built into the
                                agent

===>  net-snmp-5.3.2.3 has known vulnerabilities:
=> net-snmp -- DoS for SNMP agent via crafted GETBULK request.
   Reference: 
<http://www.FreeBSD.org/ports/portaudit/daf045d7-b211-11dd-a987-000c29ca8953.html>
=> Please update your ports tree and try again.
*** Error code 1

Stop in /usr/ports/net-mgmt/net-snmp53.
** Command failed (exit code 1): make UPGRADE_PKG=net-snmp-5.3.2_3
UPGRADE_PKG_VER=5.3.2_3
** Fix the problem and try again.

--->  Processed 1: 0 done, 0 ignored, 0 skipped, 1 failed

The port is trying to be upgraded with the same version as installed or?
_______________________________________________
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to