Jeremy Chadwick <[EMAIL PROTECTED]> escribió:

On Sun, Nov 16, 2008 at 09:43:39AM -0600, [EMAIL PROTECTED] wrote:
Test example.

I need to sync a directory from my machine to another that is using port
722 rather than 22.  I can use ssh -pm722, scp -P 722 fine but I prefer
rsync for the backup due to configuration flexibility.  The man says:

rsync [OPTION...] SRC... rsync://[EMAIL PROTECTED]:PORT]/DEST

Which I translate to something like:

rsync -avz /almacen/testDir rsync://backupMachine.com:722/backup/

but I get the following:

rsync: server sent "SSH-2.0-OpenSSH_5.1p1 FreeBSD-20080901" rather than
greeting
rsync error: error starting client-server protocol (code 5) at
main.c(1504) [sender=3.0.4]

I've tried variants to the point of no return.  Help would be appreciated.

Check out the -e flag for rsync.  There are examples of how to use this
inside of the rsync(1) man page.

I can't believe I missed that. Unfortunately I found the other first. Just for the record. a simple:

rsync -avze 'ssh -p 722' /almacen/TestDir backupMachine.com:/backup/

worked as expected.

Thanks,

ed

P.S. I also apologize to the list for sending two emails in the morning. I thought I had canceled the first but yet another error. I shouldn't work on Sundays ;)

--
| Jeremy Chadwick                                jdc at parodius.com |
| Parodius Networking                       http://www.parodius.com/ |
| UNIX Systems Administrator                  Mountain View, CA, USA |
| Making life hard for others since 1977.              PGP: 4BD6C0CB |



_______________________________________________
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to