Fbsd1 wrote:
Tried to pkg_add -r limewire. Dependant diablo-jdk- File unavailable. The package diablo-jdk is not on 7.0 or 7.1 pkg server.

Looking up diablo-jdk on the ports website, the long description points to here http://www.freebsdfoundation.org/downloads/java.shtml

Just tried to install from ports. Try to install diablo-jdk first from ports. There is a file
which should be downloaded directly from Sun, first creating your personal account @Sun. If diablo-jdk is OK, Limewire should be no problem.

# pkg_version -v|grep diablo
diablo-jdk-            =   up-to-date with port


# cd /usr/ports/net-p2p/limewire

# make
===>  Vulnerability check disabled, database not found
=> LimeWireOther.zip doesn't seem to exist in /usr/ports/distfiles/.
=> Attempting to fetch from http://www10.limewire.com/download/.
LimeWireOther.zip 100% of 9 MB 315 kBps 00m00s
===>  Extracting for limewire-4.18.8,1
=> MD5 Checksum OK for LimeWireOther.zip.
=> SHA256 Checksum OK for LimeWireOther.zip.
===>   limewire-4.18.8,1 depends on executable: unzip - found
===>  Patching for limewire-4.18.8,1
===>  Configuring for limewire-4.18.8,1

# make install
===>  Installing for limewire-4.18.8,1
===>   limewire-4.18.8,1 depends on executable: java - found
===> limewire-4.18.8,1 depends on file: /usr/local/diablo-jdk1.6.0/bin/java - found
===>   Generating temporary packing list
===>  Checking if net-p2p/limewire already installed
install -o root -g wheel -m 555 /usr/ports/net-p2p/limewire/work/limewire.sh /usr/local/bin/limewire
/bin/mkdir -p /usr/local/share/java/limewire
/bin/cp -R /usr/ports/net-p2p/limewire/work/LimeWire/* /usr/local/share/java/limewire/
/bin/mkdir -p /usr/local/share/doc/limewire
install -o root -g wheel -m 444 /usr/ports/net-p2p/limewire/work/README.txt /usr/local/share/doc/limewire/
===>   Registering installation for limewire-4.18.8,1


freebsd-questions@freebsd.org mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to