Hi all,

I ran into a weird problem when enabling serial console on the FreeBSD
7.0. Your help is really appreciated.
I installed FreeBSD 7.0 amd64 (from the CD) on a Dell R200, and then
enabled the serial console by adding the following to
/boot/loader.conf

hint.sio.0.flags="0x30"
console="comconsole vidconsole"
comconsole_speed="9600"
boot_multicons="yes"

And also replaced the following line on /etc/ttys

ttyd0  "/usr/libexec/getty std.9600"   dialup  off secure

with

ttyd0   "/usr/libexec/getty std.9600"  vt220  on   secure.

During rebooting, I found that the system hangs with the following
messages and interrupt looks totally messed up

"
...
Trying to mount root from ufs:/dev/ad4s1a

Manual root filesystem specification:
  <fstype>:<device>  Mount <device> using filesystem <fstype>
                       eg. ufs:da0s1a
  ?                  List valid disk boot devices
  <empty line>       Abort manual input

mountroot>

..."

And to my surprise, if I keep rebooting again and again without doing
any fixing, the problem comes and goes, which confused me.
When the problem is not present, the serial console looks working
normally. Can anyone help me with that? Thanks a lot.

Jim

PS. the booting messages
=============================================================
Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
      The Regents of the University of California. All rights reserved.
FreeBSD is a registered trademark of The FreeBSD Foundation.
FreeBSD 7.0-RELEASE #0: Sun Feb 24 10:35:36 UTC 2008
    [EMAIL PROTECTED]:/usr/obj/usr/src/sys/GENERIC
Timecounter "i8254" frequency 1193182 Hz quality 0
CPU: Intel(R) Xeon(R) CPU           E3110  @ 3.00GHz (3000.23-MHz K8-class CPU)
  Origin = "GenuineIntel"  Id = 0x10676  Stepping = 6
  
Features=0xbfebfbff<FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CLFLUSH,DTS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE>
  
Features2=0x8e3fd<SSE3,RSVD2,MON,DS_CPL,VMX,SMX,EST,TM2,SSSE3,CX16,xTPR,PDCM,<b19>>
  AMD Features=0x20100800<SYSCALL,NX,LM>
  AMD Features2=0x1<LAHF>
  Cores per package: 2
...
kbd1 at kbdmux0
ath_hal: 0.9.20.3 (AR5210, AR5211, AR5212, RF5111, RF5112, RF2413, RF5413)
hptrr: HPT RocketRAID controller driver v1.1 (Feb 24 2008 10:34:18)
cpu0 on motherboard
est0: <Enhanced SpeedStep Frequency Control> on cpu0
est: CPU supports Enhanced Speedstep, but is not recognized.
est: cpu_vendor GenuineIntel, msr 613091f06000613
device_attach: est0 attach returned 6
p4tcc0: <CPU Frequency Thermal Control> on cpu0
pcib0: <Host to PCI bridge> pcibus 0 on motherboard
pci0: <PCI bus> on pcib0
pcib1: <PCI-PCI bridge> irq 15 at device 1.0 on pci0
pci1: <PCI bus> on pcib1
em0: <Intel(R) PRO/1000 Network Connection Version - 6.7.3> port
0xece0-0xecff mem 0xdfbc0000-0xdfbdffff,0xdfbe0000-0xdfbfffff irq 15
at device 0.0 on pci1
em0: Unable to allocate bus resource: interrupt
em0: Allocation of PCI resources failed
device_attach: em0 attach returned 6
pcib2: <PCI-PCI bridge> irq 15 at device 28.0 on pci0
pci2: <PCI bus> on pcib2
em1: <Intel(R) PRO/1000 Network Connection Version - 6.7.3> port
0xdce0-0xdcff mem 0xdfcc0000-0xdfcdffff,0xdfce0000-0xdfcfffff irq 15
at device 0.0 on pci2
em1: Unable to allocate bus resource: interrupt
em1: Allocation of PCI resources failed
device_attach: em1 attach returned 6
pcib3: <PCI-PCI bridge> irq 15 at device 28.4 on pci0
pci3: <PCI bus> on pcib3
bge0: <Broadcom NetXtreme Gigabit Ethernet Controller, ASIC rev.
0x4201> mem 0xdfdf0000-0xdfdfffff irq 15 at device 0.0 on pci3
bge0: couldn't map interrupt
device_attach: bge0 attach returned 6
pcib4: <PCI-PCI bridge> irq 14 at device 28.5 on pci0
pci4: <PCI bus> on pcib4
bge1: <Broadcom NetXtreme Gigabit Ethernet Controller, ASIC rev.
0x4201> mem 0xdfef0000-0xdfefffff irq 14 at device 0.0 on pci4
bge1: couldn't map interrupt
device_attach: bge1 attach returned 6
uhci0: <UHCI (generic) USB controller> port 0xbc60-0xbc7f irq 11 at
device 29.0 on pci0
uhci0: Could not allocate irq
device_attach: uhci0 attach returned 6
uhci1: <UHCI (generic) USB controller> port 0xbc80-0xbc9f irq 10 at
device 29.1 on pci0
uhci1: Could not allocate irq
device_attach: uhci1 attach returned 6
uhci2: <UHCI (generic) USB controller> port 0xbca0-0xbcbf irq 11 at
device 29.2 on pci0
uhci2: Could not allocate irq
device_attach: uhci2 attach returned 6
ehci0: <EHCI (generic) USB 2.0 controller> mem 0xdfaffc00-0xdfafffff
irq 11 at device 29.7 on pci0
ehci0: Could not allocate irq
device_attach: ehci0 attach returned 6
pcib5: <PCI-PCI bridge> at device 30.0 on pci0
pci5: <PCI bus> on pcib5
vgapci0: <VGA-compatible display> port 0xcc00-0xccff mem
0xd0000000-0xd7ffffff,0xdfff0000-0xdfffffff irq 5 at device 5.0 on
pci5
isab0: <PCI-ISA bridge> at device 31.0 on pci0
isa0: <ISA bus> on isab0
atapci0: <Intel ICH9 SATA300 controller> port
0xbc30-0xbc37,0xbc28-0xbc2b,0xbc38-0xbc3f,0xbc2c-0xbc2f,0xbc40-0xbc4f,0xbc50-0xbc5f
irq 6 at device 31.2 on pci0
atapci0: unable to map interrupt
device_attach: atapci0 attach returned 6
orm0: <ISA Option ROMs> at iomem
0xc0000-0xc8fff,0xc9000-0xc9fff,0xca000-0xcb7ff,0xec000-0xeffff on
isa0
atkbdc0: <Keyboard controller (i8042)> at port 0x60,0x64 on isa0
fdc0: cannot reserve interrupt line
ppc0: cannot reserve I/O port range
sc0: <System console> at flags 0x100 on isa0
sc0: VGA <16 virtual consoles, flags=0x300>
sio0: configured irq 4 not in bitmap of probed irqs 0
sio0: port may not be enabled
sio0: configured irq 4 not in bitmap of probed irqs 0
sio0: port may not be enabled
sio0 at port 0x3f8-0x3ff irq 4 flags 0x30 on isa0
sio0: type 16550A, console
sio1: configured irq 3 not in bitmap of probed irqs 0
sio1: port may not be enabled
vga0: <Generic ISA VGA> at port 0x3c0-0x3df iomem 0xa0000-0xbffff on isa0
Timecounter "TSC" frequency 3000226239 Hz quality 800
Timecounters tick every 1.000 msec
hptrr: no controller detected.
Trying to mount root from ufs:/dev/ad4s1a

Manual root filesystem specification:
  <fstype>:<device>  Mount <device> using filesystem <fstype>
                       eg. ufs:da0s1a
  ?                  List valid disk boot devices
  <empty line>       Abort manual input

mountroot> ?

List of GEOM managed disk devices:


Manual root filesystem specification:
  <fstype>:<device>  Mount <device> using filesystem <fstype>
                       eg. ufs:da0s1a
  ?                  List valid disk boot devices
  <empty line>       Abort manual input

mountroot> ufs:ad4s1a
Trying to mount root from ufs:ad4s1a

Manual root filesystem specification:
  <fstype>:<device>  Mount <device> using filesystem <fstype>
                       eg. ufs:da0s1a
  ?                  List valid disk boot devices
  <empty line>       Abort manual input

mountroot> ?

List of GEOM managed disk devices:


Manual root filesystem specification:
  <fstype>:<device>  Mount <device> using filesystem <fstype>
                       eg. ufs:da0s1a
  ?                  List valid disk boot devices
  <empty line>       Abort manual input

mountroot> ufs:/ad4s1a
Trying to mount root from ufs:/ad4s1a

Manual root filesystem specification:
  <fstype>:<device>  Mount <device> using filesystem <fstype>
                       eg. ufs:da0s1a
  ?                  List valid disk boot devices
  <empty line>       Abort manual input

mountroot>
_______________________________________________
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to