[EMAIL PROTECTED] writes:

>  I have a really weird problem. After changing the mount point of a Linux
>  ext3 fs to a different device, the mount point disappears after mounting
>  and is inaccessible.
>
>  Disk layout:
>  ad4s1 Linux ext3
>  ad4s2 FreeBSD
>  ad4s3 Linux ext3
>  ad4s4 ext
>  ad4s5 Linux swap
>  ad4s6 Linux ext3
>  ad4s7 Linux ext3
>  ad4s8 Linux ext3
>
>  Mounting ad4s7 under FreeBSD as
>
> /dev/ad4s7              /gentoo-portage ext2fs  rw              0       0
>
>  Then I moved this data to ad4s8 and changed the fstab entry accordingly:
>
> /dev/ad4s8              /gentoo-portage ext2fs  rw              0       0
>
>  And this happens:
>
> [EMAIL PROTECTED] ~]# cd /
> [EMAIL PROTECTED] /]# ls
> .cshrc         cdrom          etc            mnt            tmp
> .profile       compat         gentoo-portage proc           usr
> .snap          dev            home           rescue         var
> COPYRIGHT      dist           lib            root
> bin            distfiles      libexec        sbin
> boot           entropy        media          sys
> [EMAIL PROTECTED] /]# mount /gentoo-portage 
> [EMAIL PROTECTED] /]# df
> Filesystem  1K-blocks    Used    Avail Capacity  Mounted on
> /dev/ad4s2a   1012974  345748   586190    37%    /
> devfs               1       1        0   100%    /dev
> /dev/ad4s2f   1010964   22324   907764     2%    /home
> /dev/ad4s2d   4058062      38  3733380     0%    /tmp
> /dev/ad4s2e  20308398 6763976 11919752    36%    /usr
> procfs              4       4        0   100%    /proc
> linprocfs           4       4        0   100%    /usr/compat/linux/proc
> /dev/ad4s8    9929540 4505212  4923908    48%    /gentoo-portage
> [EMAIL PROTECTED] /]# ls
> ls: gentoo-portage: Bad file descriptor
> .cshrc    bin       dev       etc       media     root      usr
> .profile  boot      dist      home      mnt       sbin      var
> .snap     cdrom     distfiles lib       proc      sys       z
> COPYRIGHT compat    entropy   libexec   rescue    tmp
> [EMAIL PROTECTED] /]# uname -a
> FreeBSD jeanie.my.domain 7.1-PRERELEASE FreeBSD 7.1-PRERELEASE #8: Mon Sep  1 
> 09:14:51 IST 2008     [EMAIL PROTECTED]:/usr/obj/usr/src/sys/JEANIE  i386
>
>  I changed the filesystem on /dev/ad4s8 to ext2, but the problem persists.
>  No idea what's going on :-/

Did you try an fsck on ad4s8?


-- 
Lowell Gilbert, embedded/networking software engineer, Boston area
                http://be-well.ilk.org/~lowell/
_______________________________________________
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to