I need some help with a USB connected hard drive.

It's the old drive from my 6.3-RELEASE desktop (now de-commissioned), placed 
into a IDE-USB enclosure.

It has 4 slices - a FAT32 one, a UFS2 1, a Linux (ext3 I think - was Ubuntu) 
and a Linux swap. 7.1 can see all the partitions:

******* Working on device /dev/da0 *******
parameters extracted from in-core disklabel are:
cylinders=4863 heads=255 sectors/track=63 (16065 blks/cyl)

Figures below won't work with BIOS for partitions not in cyl 1
parameters to be used for BIOS calculations are:
cylinders=4863 heads=255 sectors/track=63 (16065 blks/cyl)

Media sector size is 512
Warning: BIOS sector numbering starts with sector 1
Information from DOS bootblock is:
The data for partition 1 is:
sysid 12 (0x0c),(DOS or Windows 95 with 32 bit FAT (LBA))
    start 63, size 39070017 (19077 Meg), flag 80 (active)
        beg: cyl 256/ head 0/ sector 0;
        end: cyl 1023/ head 15/ sector 63
The data for partition 2 is:
sysid 165 (0xa5),(FreeBSD/NetBSD/386BSD)
    start 39070080, size 20964825 (10236 Meg), flag 0
        beg: cyl 1023/ head 255/ sector 63;
        end: cyl 1023/ head 6/ sector 63
The data for partition 3 is:
sysid 131 (0x83),(Linux native)
    start 60034905, size 17575110 (8581 Meg), flag 0
        beg: cyl 1023/ head 254/ sector 63;
        end: cyl 1023/ head 254/ sector 63
The data for partition 4 is:
sysid 130 (0x82),(Linux swap or Solaris x86)
    start 77610015, size 546210 (266 Meg), flag 0
        beg: cyl 1023/ head 254/ sector 63;
        end: cyl 1023/ head 254/ sector 63

and it appears in dmesg:

Dec 19 21:29:04 laptop kernel: umass0: <Super Top USB 2.0  IDE DEVICE, class 
0/0, rev 2.00/2.01, addr 2> on uhub4
Dec 19 21:29:04 laptop root: Unknown USB device: vendor 0x14cd product 0x6600 
bus uhub4
Dec 19 21:29:04 laptop kernel: da0 at umass-sim0 bus 0 target 0 lun 0
Dec 19 21:29:04 laptop kernel: da0: <WDC WD40 0BB-75DEA0 \0000\0000> Fixed 
Direct Access SCSI-0 device 
Dec 19 21:29:04 laptop kernel: da0: 40.000MB/s transfers
Dec 19 21:29:04 laptop kernel: da0: 38146MB (78125000 512 byte sectors: 255H 
63S/T 4863C)

I can successfully mount the FAT32 slices and the UFS2 partitions, but once 
mounted I can't see any files.

My son's Win XP desktop can see the FAT32 slice and all the files on it - but 
not the UFS2 or Linux slices.

The drive inside the enclosure is set to cable-select. The manual recommends 
master, but if I set it to that neither FreeBSD nor Win XP see anything (ie. 
nothing in dmesg).

Any suggestions as to what I can do to get FreeBSD to 'see' my files?


TIA.


Peter Harrison.
_______________________________________________
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "freebsd-questions-unsubscr...@freebsd.org"

Reply via email to