Tim Kellers wrote:
I just portupgraded an instance of Mailman from 2.1b4 to 2.1.1 and, while I was able to set the GID without a problem (sendmail MTA), I had this response to both /usr/local/etc/rc.d/mailman.sh start and mailmanctl:

eris# ./mailmanctl -s start
Site list is missing: mailman

I compared the files in /usr/local/mailman/bin with another machine that's running 2.1b4 and I didn't find anything startlingly different --even the Defaults.py and mm_cfg.py files were the same.

I ftp'd the mailmanctl file from the 2.1b4 server to the server with 2.1.1 installed, ran the mailman.sh start script and everything (appears, so far) to be working fine. Just to verify that it wasn't a portupgrade issue, I pkg_delete'd mailman and built a fresh install; I got the same error on starting mailmanctl with the file from 2.1.1.

Looks like 2.1.1 has some issues, has anyone gotten it to run out-of-the-box from ports??

Tim Kellers
CPE/NJIT

Hi, Tim


From /usr/local/share/doc/mailman/NEWS:

        o There is now a `site list' which is a mailing list that must
          be created first, and from which all password reminders
          appear to come from.  It is recommended that this list be
          called "[EMAIL PROTECTED]".

After creating the above list, mailmanctl worked!

Heinrich

--

Heinrich Rebehn

University of Bremen
Physics / Electrical and Electronics Engineering
- Department of Telecommunications -

E-mail: mailto:[EMAIL PROTECTED]
Phone : +49/421/218-4664
Fax   :            -3341


To Unsubscribe: send mail to [EMAIL PROTECTED] with "unsubscribe freebsd-questions" in the body of the message

Reply via email to