I am new to bsd. I'm trying to upgrade from 6.3 Release to the latest stable 7.

I created the following csup file

*default host=cvsup1.ca.FreeBSD.org
*default base=/var/db
*default prefix=/usr
*default release=cvs tag=RELENG_7
*default delete use-rel-suffix
*default compress

I then used csup to get all the source files. I cd'd to /usr/scr and tried to run make buildworld and after 15-20 min get this error.

I have tried cleaning up with

# chflags -R noschg /usr/obj/usr
# rm -rf /usr/obj/usr
# cd /usr/src
# make cleandir
# make cleandir

Still I get the error.

mv -f term.h.new term.h
cc -o make_keys -O2 -fno-strict-aliasing -pipe -I. -I/usr/obj/usr/src/ lib/ncurses/ncurses/../ncurses -I/usr/src/lib/ncurses/ncurses/../ ncurses -I/usr/src/lib/ncurses/ncurses/../ncurses -I/usr/src/lib/ ncurses/ncurses/../../../contrib/ncurses/include -I/usr/src/lib/ ncurses/ncurses/../../../contrib/ncurses/ncurses -Wall -DNDEBUG - DHAVE_CONFIG_H -DFREEBSD_NATIVE -DTERMIOS /usr/src/lib/ncurses/ ncurses/../../../contrib/ncurses/ncurses/tinfo/make_keys.c
./make_keys keys.list > init_keytry.h
/libexec/ld-elf.so.1: Shared object "libc.so.7" not found, required by "make_keys"
*** Error code 1

Stop in /usr/src/lib/ncurses/ncurses.
*** Error code 1

Stop in /usr/src.
*** Error code 1

Stop in /usr/src.
*** Error code 1

Stop in /usr/src.
*** Error code 1

Stop in /usr/src.

# uname -a
FreeBSD .no.shawcable.net 6.3-RELEASE FreeBSD 6.3-RELEASE #0: Wed Jan 16 04:18:52 UTC 2008 r...@dessler.cse.buffalo.edu:/usr/obj/usr/src/ sys/GENERIC i386

Thanks in advance for your help. _______________________________________________
freebsd-questions@freebsd.org mailing list
To unsubscribe, send any mail to "freebsd-questions-unsubscr...@freebsd.org"

Reply via email to