I'm having a tussle with one of those things I've done a zillion times, but now I can't fathom what the heck is wrong.

When I run flexbackup from a cron job (as root) , the following error is returned by e-mail to root:


Errors:
mbuffer not found in $PATH
dump not found in $PATH
restore not found in $PATH

$PATH is set in root's crontab: $PATH = "/sbin /bin /usr/sbin /usr/bin /usr/games /usr/local/sbin /usr/local/bin"

mbuffer is in /usr/local/bin and dump and restore are in /sbin

The cron'd command is: /usr/local/bin/perl /usr/local/bin/flexbackup -set backup -level incremental The machine is: Dell 2850 7.1-PRERELEASE FreeBSD 7.1-PRERELEASE #0: Sat Dec 27 03:44:52 EST 2008 amd64

When I run the command from Webin's interface for scheduled cron jobs, the command completes successfully

I know I'm missing something stupid, and I'm willing to wear the pointy hat if someone can enlighten me, somehow.

Tim Kellers

_______________________________________________
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "freebsd-questions-unsubscr...@freebsd.org"

Reply via email to