On Mon, Jan 12, 2009 at 8:08 PM, Neal Hogan <nealho...@gmail.com> wrote:
> I installed the firmware stuff from the dragonfly bwi(4) man page, yet I
> have the same issue. Is there a way to tell whether the firmware they
> provide supports my card? Like I said, I can locate my access point (and
> others that are around) and ask for an IP . . . it seems as though I'm so
> close. I'm fairly certain that I have all of the avliable bwi(4) bits
> installed correctly.
>
> I dwonloaded and installed the driver and added *if_bwi_load="YES"* in my
> loader.conf. I loaded the .ko file (bwi_v3). I downloaded and installed the
> firmware from dflyBSD and followed their directions. Yet I get no offer. Is
> the fact that I fail to get an offer indicate the firmware incompatinbility?

9 in BCM94306MP indicates that its supports 80211n and as such certainly
it is not supported with bwi(4) and reason is that bwi developers do not
plan to add support for 4 version firmware (when last time I played with bwi).

> Anyway, thanks for you help.
>
> On Mon, Jan 12, 2009 at 12:32 PM, Paul B. Mahol <one...@gmail.com> wrote:
>>
>> On 1/12/09, Neal Hogan <nealho...@gmail.com> wrote:
>> > Hello,
>> >
>> >    I am attempting to get by broadcom wifi card up and running, am sick
>> > of
>> > trying to get ndis working, and am attempting to use the bwi driver
>> > (originating in dragonflyBSD). I'm hoping others here have tried to do
>> > the
>> > same and have some pointers. I'm using 7.1-RELEASE (system/source are
>> > in-sync) and my card is a BCM94306MP. My dmesg is posted below.
>> >
>> > Bwi(4) is installed and it recognizes my card (*if_bwi_load-"YES"* is in
>> > my
>> > /etc/rc.conf and *bwi_v3* and *if_bwi* are loaded). I can send a IP
>> > request
>> > to my WEP encrypted access point. Yet, it doesn't get an offer and says
>> > that
>> > *no DS tssi* and *no OFDM tssi* Being new to bwi(4) and have never seen
>> > references to DS/OFDM tssi, I'm not sure what info to provide. My
>> > research
>> > is not leading anywhere helpful.  Thanks.
>> >
>> >
>> >
>> >
>> > Copyright (c) 1992-2009 The FreeBSD Project.
>> > Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
>> >       The Regents of the University of California. All rights reserved.
>> > FreeBSD is a registered trademark of The FreeBSD Foundation.
>> > FreeBSD 7.1-RELEASE #0: Sat Jan 10 19:07:15 CST 2009
>> >     n...@frege.lambdaserver:/usr/obj/usr/src/sys/GENERIC
>> > Timecounter "i8254" frequency 1193182 Hz quality 0
>> > CPU: mobile AMD Athlon(tm) XP2400+ (1788.94-MHz 686-class CPU)
>> >   Origin = "AuthenticAMD"  Id = 0x6a0  Stepping = 0
>> >
>> >
>> > Features=0x383f9ff<FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,MMX,FXSR,SSE>
>> >   AMD Features=0xc0480800<SYSCALL,MP,MMX+,3DNow!+,3DNow!>
>> > real memory  = 468647936 (446 MB)
>> > avail memory = 444530688 (423 MB)
>> > kbd1 at kbdmux0
>> > ath_hal: 0.9.20.3 (AR5210, AR5211, AR5212, RF5111, RF5112, RF2413,
>> > RF5413)
>> > acpi0: <PTLTD   RSDT> on motherboard
>> > acpi0: [ITHREAD]
>> > acpi0: Power Button (fixed)
>> > Timecounter "ACPI-safe" frequency 3579545 Hz quality 850
>> > acpi_timer0: <32-bit timer at 3.579545MHz> port 0x8008-0x800b on acpi0
>> > acpi_ec0: <Embedded Controller: GPE 0x18> port 0x62,0x66 on acpi0
>> > pcib0: <ACPI Host-PCI bridge> port 0xcf8-0xcff on acpi0
>> > pci_link5: BIOS IRQ 10 for 0.10.INTA is invalid
>> > pci0: <ACPI PCI bus> on pcib0
>> > agp0: <ATI RS100 AGP bridge> on hostb0
>> > pcib1: <ACPI PCI-PCI bridge> at device 1.0 on pci0
>> > pci1: <ACPI PCI bus> on pcib1
>> > vgapci0: <VGA-compatible display> port 0x9000-0x90ff mem
>> > 0xe0000000-0xefffffff,0xd0100000-0xd010ffff irq 10 at device 5.0 on
>> > pci1
>> > ohci0: <AcerLabs M5237 (Aladdin-V) USB controller> mem
>> > 0xd0006000-0xd0006fff irq 9 at device 2.0 on pci0
>> > ohci0: [GIANT-LOCKED]
>> > ohci0: [ITHREAD]
>> > usb0: OHCI version 1.0, legacy support
>> > usb0: SMM does not respond, resetting
>> > usb0: <AcerLabs M5237 (Aladdin-V) USB controller> on ohci0
>> > usb0: USB revision 1.0
>> > uhub0: <AcerLabs OHCI root hub, class 9/0, rev 1.00/1.00, addr 1> on
>> > usb0
>> > uhub0: 4 ports with 4 removable, self powered
>> > pcm0: <Acer Labs M5451> port 0x8400-0x84ff mem 0xd0007000-0xd0007fff
>> > irq 5 at device 6.0 on pci0
>> > pcm0: <Conexant CX20468 AC97 Codec>
>> > pcm0: [GIANT-LOCKED]
>> > pcm0: [ITHREAD]
>> > isab0: <PCI-ISA bridge> at device 7.0 on pci0
>> > isa0: <ISA bus> on isab0
>> > pci0: <simple comms, generic modem> at device 8.0 (no driver attached)
>> > bwi0: <Broadcom BCM4306v1 802.11 Wireless Lan> mem
>> > 0xd0004000-0xd0005fff irq 9 at device 9.0 on pci0
>> > bwi0: [ITHREAD]
>> > bwi0: regwin: chipcommon (0x800), rev 2, vendor 0x4243
>> > bwi0: BBP: id 0x4306, rev 0x2, pkg 0
>> > bwi0: nregwin 6, cap 0x0000002a
>> > bwi0: regwin: 802.11 MAC (0x812), rev 4, vendor 0x4243
>> > bwi0: has TX stats
>> > bwi0: MAC: rev 4
>> > bwi0: regwin: pcmcia (0x80d), rev 1, vendor 0x4243
>> > bwi0: regwin: v90 codec (0x807), rev 1, vendor 0x4243
>> > bwi0: regwin: pci (0x804), rev 7, vendor 0x4243
>> > bwi0: regwin: 802.11 MAC (0x812), rev 4, vendor 0x4243
>> > bwi0: ignore second MAC
>> > bwi0: bus rev 0
>> > bwi0: pci is enabled
>> > bwi0: card flags 0x000f
>> > bwi0: 0th led, act 3, lowact 0
>> > bwi0: 1th led, act 5, lowact 0
>> > bwi0: 2th led, act 4, lowact 0
>> > bwi0: 3th led, act 0, lowact 0
>> > bwi0: 802.11 MAC was already disabled
>> > bwi0: PHY is linked
>> > bwi0: PHY: type 2, rev 1, ver 1
>> > bwi0: PHY: 802.11G attach
>> > bwi0: RF: manu 0x17f, type 0x2050, rev 2
>> > bwi0: bus rev 0
>> > bwi0: PHY is linked
>> > bwi0: 30bit bus space
>> > bwi0: max txpower from sprom: 57 dBm
>> > bwi0: invalid antenna gain in sprom
>> > bwi0: ant gain 8 dBm
>> > bwi0: region/domain max txpower 76 dBm
>> > bwi0: max txpower 57 dBm
>> > bwi0: sprom idle tssi: 0x003e
>> > bwi0: TSSI-TX power map:
>> > 71 71 70 70 70 70 70 69
>> > 69 69 69 69 68 68 68 67
>> > 67 67 66 66 66 66 65 65
>> > 65 64 64 64 63 63 63 62
>> > 61 61 61 60 59 59 58 57
>> > 57 55 55 54 53 52 51 50
>> > 49 48 47 44 43 42 39 37
>> > 35 32 29 26 22 18 14 8
>> > bwi0: idle tssi0: 62
>> > bwi0: bus rev 0
>> > bwi0: locale: 6
>> > bwi0: WARNING: using obsoleted if_watchdog interface
>> > bwi0: Ethernet address: 00:90:4b:61:02:45
>> > cbb0: <O2Micro OZ6912/6972 PCI-CardBus Bridge> irq 11 at device 10.0 on
>> > pci0
>> > cardbus0: <CardBus bus> on cbb0
>> > pccard0: <16-bit PCCard bus> on cbb0
>> > cbb0: [ITHREAD]
>> > fwohci0: <Texas Instruments TSB43AB21/A/AI/A-EP> mem
>> > 0xd0009000-0xd00097ff,0xd0000000-0xd0003fff irq 10 at device 12.0 on
>> > pci0
>> > fwohci0: [FILTER]
>> > fwohci0: OHCI version 1.10 (ROM=1)
>> > fwohci0: No. of Isochronous channels is 4.
>> > fwohci0: EUI64 00:0d:9d:71:9e:43:0c:6a
>> > fwohci0: Phy 1394a available S400, 1 ports.
>> > fwohci0: Link S400, max_rec 2048 bytes.
>> > firewire0: <IEEE1394(FireWire) bus> on fwohci0
>> > fwe0: <Ethernet over FireWire> on firewire0
>> > if_fwe0: Fake Ethernet address: 02:0d:9d:43:0c:6a
>> > fwe0: Ethernet address: 02:0d:9d:43:0c:6a
>> > fwip0: <IP over FireWire> on firewire0
>> > fwip0: Firewire address: 00:0d:9d:71:9e:43:0c:6a @ 0xfffe00000000,
>> > S400, maxrec 2048
>> > sbp0: <SBP-2/SCSI over FireWire> on firewire0
>> > dcons_crom0: <dcons configuration ROM> on firewire0
>> > dcons_crom0: bus_addr 0x12bc000
>> > fwohci0: Initiate bus reset
>> > fwohci0: BUS reset
>> > fwohci0: node_id=0xc000ffc0, gen=1, CYCLEMASTER mode
>> > atapci0: <AcerLabs M5229 UDMA100 controller> port
>> > 0x1f0-0x1f7,0x3f6,0x170-0x177,0x376,0x8080-0x808f at device 16.0 on
>> > pci0
>> > atapci0: using PIO transfers above 137GB as workaround for 48bit DMA
>> > access bug, expect reduced performance
>> > ata0: <ATA channel 0> on atapci0
>> > ata0: [ITHREAD]
>> > ata1: <ATA channel 1> on atapci0
>> > ata1: [ITHREAD]
>> > pci0: <bridge> at device 17.0 (no driver attached)
>> > sis0: <NatSemi DP8381[56] 10/100BaseTX> port 0x8c00-0x8cff mem
>> > 0xd000a000-0xd000afff irq 11 at device 18.0 on pci0
>> > sis0: Silicon Revision: DP83816A
>> > miibus0: <MII bus> on sis0
>> > nsphyter0: <DP83815 10/100 media interface> PHY 0 on miibus0
>> > nsphyter0:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
>> > sis0: Ethernet address: 00:0d:9d:43:2b:a7
>> > sis0: [ITHREAD]
>> > acpi_button0: <Power Button> on acpi0
>> > acpi_lid0: <Control Method Lid Switch> on acpi0
>> > acpi_acad0: <AC Adapter> on acpi0
>> > battery0: <ACPI Control Method Battery> on acpi0
>> > acpi_tz0: <Thermal Zone> on acpi0
>> > atkbdc0: <Keyboard controller (i8042)> port 0x60,0x64 irq 1 on acpi0
>> > atkbd0: <AT Keyboard> irq 1 on atkbdc0
>> > kbd0 at atkbd0
>> > atkbd0: [GIANT-LOCKED]
>> > atkbd0: [ITHREAD]
>> > psm0: <PS/2 Mouse> irq 12 on atkbdc0
>> > psm0: [GIANT-LOCKED]
>> > psm0: [ITHREAD]
>> > psm0: model IntelliMouse, device ID 3
>> > fdc0: <floppy drive controller> port 0x3f0-0x3f5,0x3f7 irq 6 drq 2 on
>> > acpi0
>> > fdc0: [FILTER]
>> > sio0: <16550A-compatible COM port> port 0x3f8-0x3ff irq 4 flags 0x10 on
>> > acpi0
>> > sio0: type 16550A
>> > sio0: [FILTER]
>> > cpu0: <ACPI CPU> on acpi0
>> > powernow0: <PowerNow! K7> on cpu0
>> > pmtimer0 on isa0
>> > orm0: <ISA Option ROMs> at iomem
>> > 0xc0000-0xcefff,0xcf000-0xcf7ff,0xdb000-0xdbfff,0xdc000-0xdffff pnpid
>> > ORM0000 on isa0
>> > ppc0: <Parallel port> at port 0x378-0x37f irq 7 on isa0
>> > ppc0: SMC-like chipset (ECP/EPP/PS2/NIBBLE) in COMPATIBLE mode
>> > ppc0: FIFO with 16/16/16 bytes threshold
>> > ppbus0: <Parallel port bus> on ppc0
>> > ppbus0: [ITHREAD]
>> > ppi0: <Parallel I/O> on ppbus0
>> > plip0: <PLIP network interface> on ppbus0
>> > plip0: WARNING: using obsoleted IFF_NEEDSGIANT flag
>> > lpt0: <Printer> on ppbus0
>> > lpt0: Interrupt-driven port
>> > ppc0: [GIANT-LOCKED]
>> > ppc0: [ITHREAD]
>> > sc0: <System console> at flags 0x100 on isa0
>> > sc0: VGA <16 virtual consoles, flags=0x300>
>> > sio1: configured irq 3 not in bitmap of probed irqs 0
>> > sio1: port may not be enabled
>> > vga0: <Generic ISA VGA> at port 0x3c0-0x3df iomem 0xa0000-0xbffff on
>> > isa0
>> > ums0: <Logitech USB Receiver, class 0/0, rev 1.10/25.00, addr 2> on
>> > uhub0
>> > ums0: 16 buttons and Z dir.
>> > Timecounter "TSC" frequency 1788943467 Hz quality 800
>> > Timecounters tick every 1.000 msec
>> > firewire0: 1 nodes, maxhop <= 0, cable IRM = 0 (me)
>> > firewire0: bus manager 0 (me)
>> > ad0: 95396MB <Seagate ST9100823A 3.02> at ata0-master UDMA100
>> > acd0: CDRW <QSI CD-RW/DVD-ROM SBW-241/VH04> at ata1-master UDMA33
>> > Trying to mount root from ufs:/dev/ad0s2a
>> > bwi0: bwi_init
>> > bwi0: bwi_stop
>> > bwi0: bbp atten: 0, rf atten: 3, ctrl1: 2, ctrl2: 65535
>> > bwi0: bus rev 0
>> > bwi0: 802.11 MAC is disabled
>> > bwi0: 802.11 MAC was already disabled
>> > bwi0: PHY is linked
>> > bwi0: bus rev 0
>> > bwi0: PHY is unlinked
>> > bwi0: RF calibration value: 0x002a
>> > bwi0: bus rev 0
>> > bwi0: PHY is linked
>> > firmware_get: failed to load firmware image bwi_v3_ucode4
>> > bwi0: request firmware bwi_v3_ucode4 failed
>>
>> Looks like it either doesnt have such firmware loaded or firmware
>> is not supported for your card. bwi works only with firmware version 3
>> and not with 4.
>> To get right answer look in current openbsd and dragonfly bwi driver if
>> your BCM94306MP is listed.
>>
>> --
>> Paul
>
>
>
> --
> www.nealhogan.net
>



-- 
Paul
_______________________________________________
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "freebsd-questions-unsubscr...@freebsd.org"

Reply via email to