On Fri, Jan 9, 2009 at 10:43 AM, Brian McCann <bjmcc...@gmail.com> wrote:
>> Well this just got a LOT more frustrating and interesting.  I made a
>> stick following those directions using a new stick...worked fine,
>> booted off of it...did some work on it...somehow the filesystem got
>> very corrupted in one of various things I was doing to it (I think it
>> was when I accidentially unplugged it before running a sync and
>> umount).  I figured it'd just be easier to start over and build it
>> again from scratch.  So...I try to newfs it ("newfs -U -L FreeBSDStick
>> /dev/da1s1a", and newfs fails with "cg 0: bad magic number" .  Now I'm
>> really getting pissed.  So...I run a dd ("dd if=/dev/zero of=/dev/da1
>> bs=1m"), and do the whole thing over...here's the console output:
>> umm# dd if=/dev/zero of=/dev/da1 bs=1m
>> dd: /dev/da1: short write on character device
>> dd: /dev/da1: end of device
>> 3830+0 records in
>> 3829+1 records out
>> 4016045568 bytes transferred in 4324.380202 secs (928699 bytes/sec)
>> umm# fdisk -BI /dev/da1
>> ******* Working on device /dev/da1 *******
>> fdisk: invalid fdisk partition table found
>> fdisk: Geom not found: "da1"
>> umm# bsdlabel -B -w da1s1
>> umm# newfs -U -L FreeBSDStick /dev/da1s1a
>> /dev/da1s1a: 3827.9MB (7839640 sectors) block size 16384, fragment size 2048
>>        using 21 cylinder groups of 183.77MB, 11761 blks, 23552 inodes.
>>        with soft updates
>> super-block backups (for fsck -b #) at:
>>  160, 376512, 752864, 1129216, 1505568, 1881920, 2258272, 2634624,
>> 3010976, 3387328, 3763680, 4140032, 4516384, 4892736,
>>  5269088, 5645440, 6021792, 6398144, 6774496, 7150848, 7527200
>> cg 0: bad magic number
>> So now I'm getting seriously ticked off.  Anyone have any ideas what
>> the heck could be causing this?  This thumb drive was working fine
>> with FreeBSD!  I'm trying a dd on a thumb drive w/o specifying a block
>> size / BS...we'll see what that does...but I'm still open to
>> suggestions since I'm just about out of ideas.
>> Thanks!
>> --Brian
> To the list of things tried...add formatting the USB stick with the
> HDD Low Level Format Tool
> (http://hddguru.com/content/en/software/2006.04.12-HDD-Low-Level-Format-Tool/).
>  Still no joy...

For those following along at home, I found the cause of my problems.
It apparently all came down to the machine I was making the stick on.
Any machine that had an Intel SCB2 motherboard in it, would screw it
up.  I switched to using a different & newer machine, re-did the
directions at 
, and all my problems with it went away.  YAY!!!

Thanks to all those who provided input.  Long live FreeBSD!

Brian McCann

"I don't have to take this abuse from you -- I've got hundreds of
people waiting to abuse me."
                -- Bill Murray, "Ghostbusters"
freebsd-questions@freebsd.org mailing list
To unsubscribe, send any mail to "freebsd-questions-unsubscr...@freebsd.org"

Reply via email to