Beech Rintoul wrote:
On Friday 16 January 2009 15:15:13 Joakim Fogelberg wrote:
On Sat, Jan 17, 2009 at 12:43 AM, Rem P Roberti <>
Joakim Fogelberg wrote:
On Fri, Jan 16, 2009 at 11:09 PM, Beech Rintoul <>
What are the premissions of /usr/local/share/skype? Try doing chmod 755
/usr/local/share/skype and start with:
This did the trick for me. I just installed skype and:

will-try# ls -l /usr/local/share/ | grep skype
drwx------    6 root  wheel   512 Jan 17 00:13 skype

After changing the permissions I am able to start skype from the Gnome
Thanks for the shot, Joakim, but that didn't work either.  When calling
from user's command prompt still get the same result.  BTW, I'm using
Xfce as my desktop.

Just for the record... I'm also able to start Skype from the command

What happens if you do: /usr/local/share/skype/skype as a normal user?
Same thing: Permission denied.
I'm not sure if I really understand makefiles, but it seems to me that
/usr/local/share/skype are created with the following directive in
        @cd ${WRKSRC}/&&${COPYTREE_SHARE} "avatars icons sounds lang"

Maybe the directory should be created first? I.e. change it to the
following: @${INSTALL} -d ${PREFIX}/${SKYPEDIR}
        @cd ${WRKSRC}/&&${COPYTREE_SHARE} "avatars icons sounds lang"

copytree_share does create the dir first if it doesn't exist. FWIW, I loaded xfwm and tried to reproduce this, but it works fine as a normal user on my -current box. I doubt if it would be any different on a 7.x box. I've seen this problem once or twice before, but both me and Skype are at a loss to explain why it's happening. I'll chat with the Skype devs later this evening and see if one of them has any suggestions.


Thank you!

_______________________________________________ mailing list
To unsubscribe, send any mail to ""

Reply via email to