I can't perform user mounts for my pendrive, and I used to be able to, before
making an upgrade. Moreover, user mounts for both /dev/cd0 and /dev/fd0 are
still operational. Root mounts are possible, but it's doesn't strike me as good
practice, and it is a little bit of an annoyance. I need help, at least a hint
in some direction or other, because at this point I'm clueless.

I'm running FreeBSD 7.1-RELEASE-p2, GENERIC kernel, i386. I just did a major
ports updating, including perl-5.8.8 ==> perl-5.8.9. I ran the
perl-after-upgrade script, and warned me about possible problems with
/usr/local/sbin/snmpd and /usr/local/sbin/snmptrapd, but nothing else. I also
recently installed /usr/ports/misc/compat5x, among other ports. I have some
security and related ports installed, but they never caused problems before.

The command I used is the expected one:

  % mount -t msdosfs /dev/da0s1 ~/media/pendrive

Now it gives the following (quite uninformative) error:

  mount_msdosfs: /dev/da0s1: : Operation not permitted

Strangely enough, a user mount with a read-only option works just fine:

  % mount -o ro -t msdosfs /dev/da0s1 ~/media/pendrive

The mount point still has the same ownership (me) and permissions (755) as
before. Both /etc/devfs.rules, /etc/rc.conf and /etc/sysctl.conf have the
relevant lines for allowing user mounts, namely:

/etc/sysctl.conf    ==>  vfs.usermount=1
/etc/devfs.rules    ==>  [localrules=10]
                         add path 'da*s*' mode 0660 group usb
/etc/rc.conf        ==>  devfs_system_ruleset="localrules"

I don't recall this being necessary, but I also have devd enabled in rc.conf,
although with no special rules for umass in devd.conf. Needless to say, I belong
to group usb. This configuration worked before just fine. Any ideas?

Disfrutá los mejores contenidos en MSN Video.
freebsd-questions@freebsd.org mailing list
To unsubscribe, send any mail to "freebsd-questions-unsubscr...@freebsd.org"

Reply via email to