In my research and unwitting trials with this particular motherboard
(Gigabyte GA-MA78G-DS3H), I found that, while it is generally well tolerated
by FreeBSD 7.1-RELEASE, the onboard RAID is completely incompatible.  Even
when a RocketRAID 3120 card was used, the RAID could be built, but the ar0
device thus created, did not survive a reboot.  Also, a software RAID was
attempted -- after a minimal install from CD, the atacontrol command was
used to create RAID ar0, then (without rebooting) exiting back to the
installer, the OS was loaded onto it; however, upon reboot, ar0 could not be
found.  In other words, it could not boot from any RAID, whether by software
in FreeBSD or by hardware on RocketRAID.

The problem stems from the board's Southbridge SB700 chipset (the infamous
700 series).  This chipset is not (yet?) supported in FreeBSD.

Other notes on this board include the following:
-Generic VGA worked.
-The onboard LAN (chipset 8111C) worked in 7.1-RELEASE, but not 7.0.
-If the SATA ports are put into AHCI or Native IDE modes, individual disks
were recognized, but in RAID mode, neither the RAID nor individual disks
could be seen.
View this message in context:
Sent from the freebsd-questions mailing list archive at

_______________________________________________ mailing list
To unsubscribe, send any mail to ""

Reply via email to