Jimmie James <jimmie...@gmail.com> writes:

> While it looks like it install/runs fine (i.e, linux-flash9 works,
> skype works) the following error is show
> (process:47722): GLib-WARNING **: getpwuid_r(): failed due to unknown
> user id (0)
>
> Following this advice, all I could find,
> http://archive.netbsd.se/?ml=freebsd-emulation&a=2005-11&t=1506833
> The fix is, to tell /compat/linux/etc/nsswitch.conf to look at NIS too.
> Is UID 0 in your /etc/passwd? Can you try changeing
> /compat/linux/etc/nsswitch.conf to something like this:
>
> passwd:     files nisplus nis
> shadow:     files nisplus nis
> group:      files nisplus nis
>
> Uid 0 is in my /etc/passwd, there's no /compat/linux/etc/passwd., and
> changing /compat/linux/etc/nsswitch.conf to read the same doesn't fix
> the error message.
>
> Advice, suggestions?

Those setting for nsswitch.conf don't look right to me.
There should have been a message printed out when you installed one of
the linux_base ports, telling you how to configure it.
I think the fc4 version is the default these days; if that is what you
are using, the message is in the file
/usr/ports/emulators/linux_base-fc4/pkg-message


-- 
Lowell Gilbert, embedded/networking software engineer, Boston area
                http://be-well.ilk.org/~lowell/
_______________________________________________
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "freebsd-questions-unsubscr...@freebsd.org"

Reply via email to