Hi everyone,

Just to put you in context, I applied the following patch to make the card available:

SVN rev 186389 on 2008-12-22 00:46:22Z by yongari

Since we don't request reset for rlphy(4), the link state 'UP'
event from mii(4) may not be delivered if valid link was already
established. To address the issue, check current link state after
driving MII_TICK. This should fix a regression introduced in
r185753 on fast ethernet controllers.


I don't have any issue related to that anymore. The problem is that I get link UP/DOWN a few times per hour on 3 identical machines that I dumped/restored. They are all pluged in a Cisco switch that works fine for every other PCs.

Jan 26 06:09:15 term005 kernel: re0: link state changed to DOWN
Jan 26 06:09:17 term005 kernel: re0: link state changed to UP

I tried to switch cables, but I got the same result.

There is the pciconf -lv output:

r...@pci0:3:0:0: class=0x020000 card=0x02831028 chip=0x816810ec rev=0x02 hdr=0x00
    vendor     = 'Realtek Semiconductor'
    device     = 'RTL8168/8111 PCI-E Gigabit Ethernet NIC'
    class      = network
    subclass   = ethernet

There is the output of vmstat -i:

interrupt                          total       rate
irq18: re0 ehci0++                 63766          0
irq19: atapci0                    277001          3
cpu0: timer                    156068748       1961
Total                          156409515       1966

Could it be related to the fact that there is re0 and ehci0++ on the same IRQ?

Thank you for your help,

freebsd-questions@freebsd.org mailing list
To unsubscribe, send any mail to "freebsd-questions-unsubscr...@freebsd.org"

Reply via email to