Yesterday evening I tried upgrading my ports by using the portupgrade tool.
The exact command that I used was:

portupgrade -a --batch

All but one package failed to build properly. The offending package was git.
For some reason it could not find the p5-xyz module while these were
properly installed. Not able to get around the problem I finally tried the
FORCE_PKG_REGISTER approach after reading about this on the net and in the
output of the portupgrade run.

This installed git and I thought everything was running fine till today.
After rebooting I saw ddclient was no longer able to run. If I check
/var/log/messages it complains that it can't load p5-IO-Socket-SSL.

I can't get ddclient to work. A "make deinstall; make reinstall" does not
work. Currently I am trying "portupgrade -a -f --batch" to try and rebuild
every port on my system.

What could have been the original problem with git and how can I get out of
this nasty situation?

My system is running FreeBSD 7.1-p2.

freebsd-questions@freebsd.org mailing list
To unsubscribe, send any mail to "freebsd-questions-unsubscr...@freebsd.org"

Reply via email to