On Wed, 2009-01-28 at 14:29 -0700, Keith Seyffarth wrote:
> On freebsd 6.0, I started having issues with X on Friday, and by
> Sunday, clicking buttons on the XFCE toolbar or choosing menu items
> from the XFCE menu weren't working. Subsequent to this, X would just
> hang when I run startx.
> I think what may have started this was trying to portupgrade gnucash,
> because it looks like some port items that were dependencies for other
> things (xorg-protos, for example) have been removed from the ports
> system.
> so, I tried portupgrade for xfce4, which tells me everything is
> current. Then I tried portupgrade xorg, which did upgrade a lot of
> things.
> This got me to a point where I can run startx, and rather than
> hanging, it, um, crashes gracefully. I receive this error:
> (==) Using config file: "/etc/X11/xorg.conf"
> Parse error on line 75 of section Files in file /etc/X11/xorg.conf
>         "RgbPath" is not a valid keyword in this section.
> (EE) Problem parsing the config file
> (EE) Error parsing the config file
> Fatal server error:
> no screens found
> giving up.
> I can comment out line 75 referred to above, but that seems to put me
> back to where I was before trying to upgrade: startx hangs the
> computer...
> Does anyone have any suggestions?

Check the libxcb thread on this list. Try running portupgrade -a -rf
libxcb and wait patiently- it worked for me. Meanwhile, leave rgbpath
uncommented if you have X ttys enabled or it'll annoy the shit out of
you- comment it out as soon as portupgrade finishes and you'll have
beloved X back :)

If mouse doesn't work at this point you'll have to make sure dbus and
hald are enabled under rc.conf and reboot.

freebsd-questions@freebsd.org mailing list
To unsubscribe, send any mail to "freebsd-questions-unsubscr...@freebsd.org"

Reply via email to