On Sat, 31 Jan 2009, Keith Seyffarth wrote:

I also tried adding
AllowEmptyInput "off"
in xorg.conf, but that gives an error when starting X that
AllowEmptyInput is not valid.


In section ServerLayout, add

Option "AllowEmptyInput" "Off"

Thakns. This worked. I had the syntax incorrect. however, I thought
this wasn't supposed to be necessar after the updates to hal on the
27th?

I hadn't tested it since then, but did just now. Removing keyboard and mouse entries and AllowEmptyInput and AutoAddDevices entries in ServerLayout did work... for a few seconds.

Then it went back to keyboard input or mouse clicks ignored until the mouse is moved. That includes ctrl-alt-backspace.

This is with hal-0.5.11_14 and moused enabled, tested on two different systems. Both have a USB and PS/2 mouse.

So I'm sticking with explicitly declaring keyboard and mouse and AutoAddDevices Off for now.

-Warren Block * Rapid City, South Dakota USA
_______________________________________________
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "freebsd-questions-unsubscr...@freebsd.org"

Reply via email to