Shaun writes:

> Have you tried ^X or ^Z? Often when my cable modem has lost its link and
> I reboot, FreeBSD will hang waiting to start sendmail because it can't
> determine the local IP. Sometimes it will hang while processing my ipfw
> scripts due to DNS failures.
> I usually try ^C, ^X, and ^Z in that order and in my experience one of
> them will abort the hung process.

I tried every letter on the keyboard, ^\, a few other keys, and break
(RS-232 console).  Seems like ^\ used to be a sure kill (SIGKILL maybe?).

Tim writes:

> If a shell script traps the signals, there is nothing you can do except
> by calling a SIGKILL to the PID, which requires the system to be in
> Multi-User Mode.

The shell script doesn't, but a binary program it calls might.
I'll have to look into that.

michael writes:

> or, boot with rescue cd or anything that will write to the fs and 
> disable the script

I managed to get the boot loader to boot single user, then
moved the script to a different filename.  Added a symlink
from the script name to /bin/true, which turns out to not
exist.  Someone moved true to /usr/bin.  Fortunately the
script not existing didn't cause a problem.

Thanks, gang.  Any other ideas?

BTW, softdeps and background fsck are very much appreciated
when pressing the reset button!
_______________________________________________ mailing list
To unsubscribe, send any mail to ""

Reply via email to