Since yesterday, I get at

$ php --version
PHP Warning: PHP Startup: Unable to load dynamic library '/usr/local/lib/php/20060613/ldap.so' - Shared object "libldap-2.4.so.5" not found, required by "ldap.so" in Unknown on line 0


I see that my /usr/local/lib/ now contains lrwxr-xr-x 1 root wheel 16 Feb 23 14:09 libldap-2.4.so -> libldap-2.4.so.6
-rw-r--r--  1 root  wheel  307762 Feb 23 14:09 libldap-2.4.so.6
 etc.. so, only references to libldap-2.4.so.6, but no more libldap-2.4.so.5

Yesterday, I indeed reinstalled apache (with an extra option checked to
include some extra module)

The # make install clean
downloaded openldap-2.4.14 (up to then I had open-ldap-2.3.13) but stopped with ===> An older version of net/openldap24-client is already installed (openldap
-client-2.4.13)
      You may wish to ``make deinstall'' and install this port again
      by ``make reinstall'' to upgrade it properly.
      If you really wish to overwrite the old port of net/openldap24-client
      without deleting it first, set the variable "FORCE_PKG_REGISTER"
      in your environment or the "make install" command line.
*** Error code 1

I did
# cd /usr/ports/net/openldap24-client
# make deinstall
which said:
pkg_delete: package 'openldap-client-2.4.13' is required by these other package
s and may not be deinstalled (but I'll delete it anyway):
apache-2.2.11_3
arts-1.5.10_1,1
cups-base-1.3.9_3
cups-pstoraster-8.15.4_2
dbus-qt3-0.70_2
gconf2-2.24.0
gtk-2.14.7
gutenprint-base-5.1.7_1
gutenprint-cups-5.1.7_3
hplip-2.8.2_3
kde-3.5.10_1
kdeaccessibility-3.5.10
kdeadmin-3.5.10
kdeartwork-3.5.10_1
kdeartwork-3.5.10_1
kdebase-3.5.10_2
kdebase-kompmgr-3.5.10
kdeedu-3.5.10
kdegames-3.5.10
kdegraphics-3.5.10
kdelibs-3.5.10
kdemultimedia-3.5.10
kdenetwork-3.5.10
kdepim-3.5.10_2
kdesdk-3.5.10_1
kdetoys-3.5.10
kdeutils-3.5.10
kdevelop-3.5.3_1
kdewebdev-3.5.10_1,2
koffice-1.6.3_7,2
libgsf-1.14.11
libwpd-0.8.14_1
php5-5.2.8
php5-ctype-5.2.8
php5-dom-5.2.8
php5-extensions-1.2
php5-filter-5.2.8
php5-gd-5.2.8
php5-hash-5.2.8
php5-iconv-5.2.8
php5-json-5.2.8
php5-ldap-5.2.8_1
php5-mysql-5.2.8
php5-mysqli-5.2.8
php5-pdo-5.2.8
php5-pdo_sqlite-5.2.8
php5-posix-5.2.8
php5-session-5.2.8
php5-simplexml-5.2.8
php5-spl-5.2.8
php5-sqlite-5.2.8
php5-tokenizer-5.2.8
php5-xml-5.2.8
php5-xmlreader-5.2.8
php5-xmlwriter-5.2.8
poppler-qt-0.8.7
py25-qt-3.17.4_1,2
qscintilla-1.7.1_4
qt-3.3.8_9
subversion-1.5.5_1
wv2-0.2.3_2

# make reinstall
this ended without errors

Did I need to update php5?
I tried
# portsnap fetch
# portsnap update
# cd /usr/ports/lang/php5
# portupgrade -R php5
this only upgraded my perl to perl-5.8.9_1
but changed nothing to my PHP5 (/usr/local/bin/php same date as weeks ago)

So, this did not solve the initial problem also..

I Tried
# cd /usr/ports/net/php5-ldap
# portupgrade -R php5-ldap
[Gathering depends for net/php5-ldap ................................... done]
[Exclude up-to-date packages .................. done]
macos#
macos# make install clean
...
===>   php5-ldap-5.2.8_1 is already installed
      You may wish to ``make deinstall'' and install this port again
      by ``make reinstall'' to upgrade it properly.
      If you really wish to overwrite the old port of net/php5-ldap
      without deleting it first, set the variable "FORCE_PKG_REGISTER"
      in your environment or the "make install" command line.
*** Error code 1

So php5-ldap was already the last version...

What's going wrong and how to solve all that ?

_______________________________________________
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "freebsd-questions-unsubscr...@freebsd.org"

Reply via email to