On Thu, 26 Feb 2009 22:53:01 -0800 (PST), devindg <dgarcia.t...@gmail.com> 
wrote:
I went ahead and tried your
> suggestion, but the problem persists. However -- and I should have given
> this more thought earlier -- I looked at the Xorg log, and it may provide
> more useful information.

This is obvious:

(II) config/hal: Adding input device Logitech USB Keyboard
(II) LoadModule: "kbd"
(II) Loading /usr/local/lib/xorg/modules/input//kbd_drv.so
(II) Module kbd: vendor="X.Org Foundation"
        compiled for 1.5.3, module version = 1.3.2
        Module class: X.Org XInput Driver
        ABI class: X.Org XInput driver, version 2.1
(**) Logitech USB Keyboard: always reports core events
(**) Option "Protocol" "standard"
(**) Logitech USB Keyboard: Protocol: standard
(**) Option "Device" "/dev/ukbd0"
(EE) Logitech USB Keyboard: cannot open "/dev/ukbd0"
(EE) PreInit failed for input device "Logitech USB Keyboard"
(II) UnloadModule: "kbd"
(EE) config/hal: NewInputDeviceRequest failed

It seems to indicate a major problem with the keyboard, which
is an USB Logitech one.

Do you have the (testing) option to attach a standard keyboard,
a PS/2 102 key keyboard or at least a normal USB keyboard (Sun,
Apple)?

Because of the message

        (EE) Logitech USB Keyboard: cannot open "/dev/ukbd0"

it seems that X (or at least HAL) cannot open the keyboard's
device file /dev/ukbd0. Can you ll this file to check the existance
and correct permission?

        % ll /dev/ukbd0 
        crw-------  1 root  wheel    0, 121 Feb 28 02:34 /dev/ukbd

Is the USB keyboard detected correctly by the system for "outside
X" operations?

        % dmesg | grep ^ukbd
        ukbd0: <vendor 0x0430 product 0x0005, class 0/0, rev 1.00/1.02, addr 3> 
on uhub1

For my keyboard ONLY: Reporting defective since FreeBSD 7; should be:

        % dmesg | grep ^ukbd
        ukbd0: Sun Microsystems Type 6 USB keyboard, rev 1.00/1.02, addr 3, 
iclass 3/1

Check usbdevs -v as well.

My idea would be now that X (or HAL) misdetects your keyboard and
starts to do strange stuff when the Alt key is pressed because it
"thinks" that it isn't the Alt key, but something else.

Again, try to check with a standard keyboard, just to be sure.

Final idea: Maybe the keyboard is so non-standard that it is to
be considered crap (as it is for most "modern" stuff, especially
from today's Logitech) and should be exchanged in favour of a
regular and standard-compliant keyboard.

Since the happy X upgrades, consider the HAL and DBUS stuff to
be crap, too, especially when the keyboard worked as intended
before the upgrade. :-)



-- 
Polytropon
>From Magdeburg, Germany
Happy FreeBSD user since 4.0
Andra moi ennepe, Mousa, ...
_______________________________________________
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "freebsd-questions-unsubscr...@freebsd.org"

Reply via email to