I guess it's probably worth mentioning that I'm working with KDE 3.5.10
right now.  Is this something likely solved in KDE 4.2 so I've hit my
reason to upgrade?

Joe.

Joe Kraft wrote:

> I'm trying to implement SSO using Samba-3.2.4 with an LDAP backend.  The
> intent is to use ldap directly for FBSD clients and Samba for MS Windows
> clients.
> 
> The LDAP server (openldap 2.4.11) is running on a FBSD 6.3 server and is
> setup and seems to be working fine, I can log in locally or through SSH
> using the ldap accounts.
> 
> I'm working on the first client which is a FBSD 7.1 machine.  I can use
> ldap to login on this machine, but I'm having issues with logging in
> using kdm.  I can see all the users both from local files and from ldap,
> but I can't log in using either.  Even when kdm won't allow a login, I
> can <ctrl><alt><F8> and get a normal login shell and login with local or
> ldap accounts.  The ldap lines are included in my /etc/pam.d/kde file.
> 
> If I remove ldap from the nsswitch.conf file it will start working with
> local logins on kdm again.
> 
> I ran into a bug report from last summer that appears to still be open
> with exactly the same issue
> (http://www.freebsd.org/cgi/query-pr.cgi?pr=124321).
> 
> Does anyone know a workaround or have a patch for the issue?  I can
> provide config files and such if anyone thinks it might help.
> 
> Thanks,
> Joe.


_______________________________________________
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "freebsd-questions-unsubscr...@freebsd.org"

Reply via email to