Hello BF/Everyone,

Thanks for your advice. But the problems just don't seem to go away. I ran 'make config' inside /usr/ports/ftp/curl and was able to rectify the problem. I was installing curl as part of the xine build process. Once curl got built, xine got built too. The install went smoothly enough. But when I ran xine& from a gnome-terminal, the ui loaded, got stuck for hours and simply would not respond to any mouse clicks. I finally had to do a kill -9. (Which is why I dropped curl from the subject of this message and
replaced it with xine).

As for abiword, I downloaded the latest ports tarball a few minutes back. Building
abiword stops with pretty much the same error :

In file included from /usr/local/include/gtk-2.0/gtk/gtkactiongroup.h:34,
                 from /usr/local/include/gtk-2.0/gtk/gtk.h:38,
                 from goffice-gtk.c:27:
/usr/local/include/gtk-2.0/gtk/gtkitemfactory.h:50: warning: function declaration isn't a prototype goffice-gtk.c:1041: error: static declaration of 'gdk_cairo_set_source_pixbuf' follows non-static declaration /usr/local/include/gtk-2.0/gdk/gdkcairo.h:36: error: previous declaration of 'gdk_cairo_set_source_pixbuf' was here goffice-gtk.c:1152: error: static declaration of 'gtk_dialog_get_response_for_widget' follows non-static declaration /usr/local/include/gtk-2.0/gtk/gtkdialog.h:149: error: previous declaration of 'gtk_dialog_get_response_for_widget' was here
gmake[3]: *** [goffice-gtk.lo] Error 1
gmake[3]: Leaving directory `/usr/ports/devel/goffice04/work/goffice-0.4.3/goffice/gtk'
gmake[2]: *** [all-recursive] Error 1
gmake[2]: Leaving directory `/usr/ports/devel/goffice04/work/goffice-0.4.3/goffice'
gmake[1]: *** [all] Error 2
gmake[1]: Leaving directory `/usr/ports/devel/goffice04/work/goffice-0.4.3/goffice'
gmake: *** [all-recursive] Error 1
*** Error code 2

Stop in /usr/ports/devel/goffice04.
*** Error code 1

Stop in /usr/ports/editors/abiword.

Any help with xine and/or abiword would be greatly appreciated.

Thank you and Regards
Manish Jain
invalid.poin...@gmail.com


bf wrote:
Firstly, it looks like you are using an old ports tree.
You should update it by downloading a newer tarball or using
csup.  Read the pertinent section of the handbook if you
don't know how to do this.  This may solve your goffice
build problem. (It's actually goffice, and not abiword, that
is the problem.)  If it doesn't, send a transcript to the
port maintainer via email, or file a PR.  You should not be
attempting to use curl 7.19.2, which has security problems,
but rather the newer 7.19.4, which is in the latest ports tree.

The curl problem, as the error message says, is that you
have enabled two mutually incompatible options when configuring
the port.  I don't know what you mean by "replacing the
Makefile": you shouldn't need to replace any Makefiles. Just
rerun 'make config' in the port directory, and select either
GNUTLS or OPENSSL, but not both.  Then build the port.  The
options that you have selected for ports are not contained
in any Makefile, but rather in /var/db/ports, and can be viewed
by looking through that directory, or by running 'make showconfig' in the port 
directory.

b.


_______________________________________________
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "freebsd-questions-unsubscr...@freebsd.org"

Reply via email to