On Thu, 19 Mar 2009, Jaime wrote:

On Thu, Mar 19, 2009 at 1:39 PM, Andrew Hamilton-Wright <and...@qemg.org> wrote:
What happens if you use dd to try and write to the tape?

The command
       dd if=/dev/zero of=/dev/sa0 count=8
should print out:
       8+0 records in
       8+0 records out

I tried this and the output was:
8+0 records in
8+0 records out
4096 bytes transferred in 0.036611 secs (111879 bytes/sec)

Small write works okay...

So then I tried my backup script (which is basically a tar command)
and got this on the console:
(sa0:ahc0:0:6:0): Unexpected busfree in Data-out phase
SEQADDR == 0x86
(sa0:ahc0:0:6:0): lost device
(sa0:ahc0:0:6:0): failed to write terminating filemark(s)
(sa0:ahc0:0:6:0): tape is now frozen- use an OFFLINE, REWIND, or MTEOM
command to clear this state.
(sa0:ahc0:0:6:0): removing device entry

Bigger write fails...

On the ssh terminal / standard output, I got this:
tar: Write error: Input/output error

Now "camcontrol devlist" doesn't show the tape drive, even though it
did before.

And the device acts flaky. That screams "SCSI termination problem" to me. That would also be consistent with most/all of the tapes failing, because it's not the tapes.

...

I'm going to tinker some more and see if I can get this drive working
again.  I'll also try another tape.  (Its worth noting that I DID
manage to get a tape working thanks to mt -f /dev/sa0 fsf 1 && mt -f
/dev/sa0 rewind.)  More info later.

Try that one working tape again.  Betcha it "fails".

-Warren Block * Rapid City, South Dakota USA
_______________________________________________
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "freebsd-questions-unsubscr...@freebsd.org"

Reply via email to