On Mon, 23 Mar 2009, Neal Hogan wrote:

Well, recently I deinstalled all of my third party apps . . . long story
(some of which is documented on this list) . . . but the short story is that
some were added via the ports tree and others via pkg_add. When it came time
to portupdate, I was having problems and it was brought to my attention
that, among other things, mixing ports and packages may lead to problems.
Also, I didn't do the massive deinstall until after I had portupgraded all
of my packages individually and the mouse/keyboard didn't work with X (it
did at the console). Once this happened I felt compelled to wipe the slate.

So, with no ports/packages installed and starting with a fresh ports tree, I
began installing them one-by-one:

1) cd /usr/ports/path/port
2) make && make install && make clean

I started with xorg. After it was installed, I tried to start X (startx) . .
. no dice . . . no big deal. I created the basic xorg.conf (Xorg
-configure), tried it (Xorg -config xorg.conf.new). X started, but no mouse
activity and ctrl+alt+backspace did not quit X. I had moused enable in
rc.conf and, as I say above the mouse worked (i.e., it moved when asked) at
the console. /usr/ports/UPDATING says that some mouse issues were cleared

241   AFFECTS: users of x11-servers/xorg-server, sysutils/hal
242   AUTHOR: rnol...@freebsd.org
244   sysutils/hal has been updated and should now properly detect
245   mice for use in Xorg.  Use of AllowEmptyInput should no longer
246   be needed for most users and moused should now work fine."

But, as I say, I have no mouse under X.

Adding hal alone is not enough, you have to enable it both when you build xorg-server and in /etc/rc.conf. I use moused also, and have no AllowEmptyInput or AutoAddDevices or mouse or keyboard sections in xorg.conf.

-Warren Block * Rapid City, South Dakota USA
freebsd-questions@freebsd.org mailing list
To unsubscribe, send any mail to "freebsd-questions-unsubscr...@freebsd.org"

Reply via email to