Andrew Boothman writes:
 > [...]
 > I didn't really change much about my system when I installed FreeBSD.
 > Windows is installed on the whole of the first HDD, and FreeBSD on the whole of 
 > the second. Prior to installing 5.0, the second disc had an old installation of 
 > 4.6 that I wasn't using.
 > When installing, I asked sysinstall to install booteasy on the first drive, but 
 > otherwise leave it unchanged. I removed the existing slice on the second drive 
 > and got sysinstall to create a new slice filling the drive, I then allowed 
 > sysinstall to auto-size the partitions and complete the installation.
 > I've tried every repair option that I can find on the Win2k CD. I've tried 
 > the "fixboot" and "fixmbr" commands in the recovery console many times, and 
 > despite fixmbr complaining about an "unusual" mbr every time, installing a new 
 > one apparently makes no difference. I eventually managed to remove booteasy 
 > from the first drive so that "NTLDR is missing" appears straight away, but that 
 > is hardly a victory. I even followed Microsoft's instructions in knowledgebase 
 > article 318728 and performed a brand new installation of windows into 
 > c:\tempwin but even this new installation failed to boot with the same problem. 
 > Therefore it would seem that whatever the problem is, Win2k's setup prog either 
 > can't fix it or is oblivious to it. It's looking more and more like I'm going 
 > to have to reformat this drive as I seem to have no way of getting Win2k 
 > operating again, but I'd _really_ like to understand what happened here, not 
 > least to ensure I don't repeat the same problems when I come to try and dual-
 > boot again!
 > Apologies for this getting increasingly off-topic, but I can't understand what 
 > I've done wrong here as I've done this many times before with 4.x.
 > As ever, any light-shedding would be much appricated :)

I had several problems installing 5.0 release onto my sandbox machine,
and the solution might be relevant.

My sandbox machine had a single disk, uses a "stock" (what came on the
drive) master boot record, and had several primary partitions (aka
slices).  The first partition/slice contained a windows2000 install,
the second partition had a linux installation w/ the GRUB boot loader
installed in the beginning of the partition.  The linux parition is
marked active (using Partition Magic from windows), so the normal boot
sequence goes:

  MBR  -->  GRUB  ---+--> Linux
                     +--> Windows

depending on the choice made in grub.  I boot this way because the
sandbox machine is a test environment for my laptop, and suspend to
disk stuff doesn't seem to work on the laptop unless the vendor's MBR
is in place.

My intent was to add Freebsd to the third partition.  I ran through
the install and told the installer to just leave the MBR alone.

Among the things that I discovered were:

  - both the linux partition *AND* the newly installed FreeBSD
    partition ended up marked active.

  - There was a problem with data somewhere in the BIOS/DOS partition
    table concerning CHS values and LBA values for various parts of
    the partition.  (might have the acronym's wrong).

Both of these rendered the machine unable to boot, I recovered it once
by booting from a floppy, getting into windows, and running partition
magic, and on a separate test run by booting from a live linux cd and
playing with various fdisk-oid programs available there.

So, all that said, maybe your partition table is slightly scrod, not
so badly that it won't get through the MBR but badly enough that it
can't find the NT partition?

It'd be interesting to see what parition magic had to say about it.


To Unsubscribe: send mail to [EMAIL PROTECTED]
with "unsubscribe freebsd-questions" in the body of the message

Reply via email to