I'm cc'in this to quesitons since I had the same problem on an i386.

I installed 5.0-RELEASE directly from the CDs.

ran cvsup -g -L2 ports-supfile and standard-supfile
make buildworld -DNOGAMES -DNO_FORTRAN
mergemaster -p
make installworld  -DNOGAMES -DNO_FORTRAN 

the kernel targets work. and I am actually running that kernel 5.0-CURRENT 
RELEASE #3 right now. 

the buildworld failes 
make: don't know how to make /usr/src/sys/sys/_types.h" 
Interestingly I haven't seen any tinderbox failures come through to any lists 
about this yet.

since I see it below, in addition to make doing it, I've run rm -rf /usr/obj
before doing the buildworld.

On Monday 24 February 2003 02:11, Michael A. Smith wrote:
> Marcel Moolenaar wrote:
> > Probably a stale dependency. Try cleaning your object directory (or
> > at least all the .depend files).
> I've never done this before. How do I do it? [read below for more
> remembered details]
> Thanks!
> Bernd Walter wrote:
> > You should update to the latest -stable and then update to 5.0.
> > Updating directly with an older version might not work.
> I had the same problem trying to upgrade to RELEASE_4, which is why I
> tried to downgrade back to 4.6 (the last known good version on this box).
> > Did you run buildworld first? Otherwise you don't have updated tools
> > in /usr/obj to run buildkernel.
> Yup. I ran "make -j4 buildword" before "make buildkernel KERNCONF=ZEUS".
> In thinking this over, I *may* have remembered a clue to what's going
> on. I was wrong in the original post about getting this error when
> trying to upgrade to 5.0. World and kernel built and installed without
> error, but the machine wouldn't boot. I went back to kernel.old,
> modules.old and etc.old (I backup etc before running mergemaster). I
> then renamed kernel.old, modules.old and etc.old (to kernel, modules,
> and etc). I've rebooted several times without incident and everything
> seems to be running fine (except updating the system).
> THEN, I tried upgrading to RELEASE_4 (then 4.7) and THAT'S when I first
> saw the "make: don't know how to make /usr/src/sys/sys/_types.h" message
> when building the kernel.
> I'm thinking there MUST be tons of out-of-sync stuff in the system from
> when I ran "make installword" in the earlier 5.0 update. I went back to
> the old kernel, modules and etc, but everything else is out-of-sync.
> This might be causing this problem. This isn't a production machine, I
> can wipe and re-install, but I'd rathe rnot have to do it.

Philip M. Gollucci [EMAIL PROTECTED] 301.474.9294 301.646.3011 (cell) 

Science, Discovery, & the Universe (UMCP) 
Webmaster & Webship Teacher 
URL: http://www.sdu.umd.edu 

Database/PERL Programmer & System Admin 
URL : http://www.ejournalpress.com 

Resume : http://p6m7g8.net/Resume 

To Unsubscribe: send mail to [EMAIL PROTECTED]
with "unsubscribe freebsd-questions" in the body of the message

Reply via email to