Manolis Kiagias wrote:
Steven Friedrich wrote:
Lowell Gilbert wrote:
Steven Friedrich <> writes:

I've been having trouble with X11 ports, so I deleted all my packages
and tried to install xorg fresh.

xorg port failed trying to build cairo, cairo failed because it
couldn't build libdrm, libdrm failed because cairo's headers weren't

So in summary, I can't install cairo because it wants to build libdrm,
which won't build/install because it wants cairo.

And I tried to install packages or the X11 distro from the ftp site
and also from my 7.2 RC-1 media.  I tried setting the Options for
"any" as well as RELEASE_7_2_0, to no avail.  My system is up and
running multi-user, so sysinstall failed to install any packages.

I built cairo with make -k install, so it would brute force past the
error, and after that I built libdrm and cairo again with portupgrade
-fr libdrm cairo.
Not only have I not seen or heard of this problem before, I can't see
any direct dependency of either libdrm or cairo on the other.

pkg_info -r cairo\* shows that cairo needs libdrm.
Information for cairo-1.8.6_1,1:

Depends on:
Dependency: libdrm-2.4.9

If anyone has a has a test system, where they could try my scenario,
i.e., deleting all installed packages and trying to install xorg, I
think you'll find it.

I have two identical systems that I have mobile racks in, allowing me
to swap out the hard drives. So I have 4 sets of drives, Lightning,
Daemon, FreakinBSD, and Gandalf.  I saw this issue with Daemon.  I
need to update FreakinBSD and Gandalf, so I'll try this again and get
it in a log file.

libdrm doesn't build without cairo.h in /usr/local/include, but it
won't be there until you're built cairo, which depends on libdrm.

As Lowell already said, I can't find any dependency between libdrm and
cairo. My guess is you package database has one or more stale
dependencies. However, if the purpose is to wipe all packages you don't
even have to bother with pkg_delete. In such cases I simply  rm
/usr/local and /var/db/pkg (Keep /var/db/pkg/linux_base-fc* if you are
using the linux binary compatibility, as this is not installed in
/usr/local but /usr/compat). I do this routinely on test systems.

On a system with cairo installed, try pkg_info -r cairo\*|grep drm

Here's from one of my systems:
Dependency: libdrm-2.4.9

Since I used pkg_delete -a to get rid of all ports and packages, I couldn't have any stale dependencies, could I ?

After that I went to /usr/ports/x11/xorg and did a make install and it failed. My ports are recent, I'm tracking 7.2-RC1, etc.


Steven Friedrich
Lexington, KY 40509
_______________________________________________ mailing list
To unsubscribe, send any mail to ""

Reply via email to