Kris Kennaway wrote:

On Sun, Mar 02, 2003 at 11:08:45AM -0500, Tom Parquette wrote:



This is due to the upgrade of openssl.  Have you tried cvsupping and
retying?  Most of the problems have already been fixed.  If it
persists, then please report which port was building when it failed
(not instant-server, but one of the other ports it installs)

Kris




Kris,
Rereading my post, I should have said Postfix instead of instant-server. Sorry.
Instant-server pulls in Postfix. The problem also shows up if I try to build just Postfix.


Can I clarify "cvsupping and retrying"? My understanding is crypto is one of the FreeBSD distribution pieces. You also mentioned openssl.
Are you indicating I should cvsup and remake world/kernel or I should be looking at openssl?



cvsup the ports collection and retry the port build. Since you don't have libdes, you have a fresh installation of 4.x from within the last couple of weeks (older systems have libdes, which was included with the old openssl for compatibility). Most of the ports have been corrected already to not look for libdes.

Kris



Kris,
Reminder: As I indicated in the initial post, this is a 5.0-CURRENT system. Not 4.x...
I just cvsuped ports-all (approx 22:00 EST on 3/2/03) and tried to rerun the make for postfix.
It bombed again. I have mixed results trying to copy-and-paste from a terminal window but I was able to paste the failing compile into this entry.


Is there any other information I can supply?
Thanks for helping me with this.
Cheers...

gcc -Wmissing-prototypes -Wformat -DHAS_PCRE -I/usr/local/include -DUSE_SASL_AUTH -I/usr/local/include -I/usr/local/include/sasl -DHAS_SSL -I/usr/include/openssl -I/usr/local/include/db41 -DHAS_MYSQL -I/usr/local/include/mysql -DHAS_PGSQL -I/usr/local/include -I/usr/local/pgsql/include -DHAS_LDAP -I/usr/local/include
-O -pipe -mcpu=pentiumpro -I. -I../../include -DFREEBSD5 -o master master.o master_conf.o master_ent.o master_sig.o master_avail.o master_spawn.o master_service.o master_status.o master_listen.o master_vars.o master_wakeup.o master_flow.o ../../lib/libglobal.a ../../lib/libutil.a -L/usr/local/lib -lpcre -L/usr/local/lib -lsasl2 -lpam -lcrypt -lkrb -ldes -lcom_err -lssl -lcrypto -L/usr/local/lib
-ldb41 /usr/local/lib/mysql/libmysqlclient.a -lm -lz -L/usr/local/lib -L/usr/local/pgsql/lib -lpq -lcrypt /usr/local/lib/libldap.a /usr/local/lib/liblber.a
/usr/bin/ld: cannot find -ldes
*** Error code 1
Stop in /usr/ports/mail/postfix/work/postfix-2.0.4/src/master.
*** Error code 1
Stop in /usr/ports/mail/postfix/work/postfix-2.0.4.
*** Error code 1
Stop in /usr/ports/mail/postfix.
*** Error code 1
Stop in /usr/ports/mail/postfix.
Atlas#





To Unsubscribe: send mail to [EMAIL PROTECTED] with "unsubscribe freebsd-questions" in the body of the message

Reply via email to