Shawn Badger wrote:

   Francisco Cabrita wrote:

Hi Shawn

I would first try to figure why is this error in the logs.

(EE) XKB: No components provided for device Virtual core keyboard

I think only errors stop the X to start. The one you show are warnings.

Regards,
Francisco
  

   Thanks Francisco, I hadn't noticed this.  When I use the options
       Option "AutoAddDevices" "False"
       Option "AllowEmptyInput" "False"
   and have hald running, I then get the following errors:
       (II) config/hal: Adding input device AT Keyboard
       (EE) config/hal: NewInputDeviceRequest failed (8)
       (II) config/hal: Adding input device PS/2 Mouse
       (EE) config/hal: NewInputDeviceRequest failed (8)
       (II) UnloadModule: "mouse"
       (II) UnloadModule: "kbd"
   When looking at my running processes, there are 3 hal-related
   processes:
       hald-runner
       hald-addon-mouse-sysmouse: /dev/psm0
       hald-addon-storage: /dev/acd0
   oops, /usr/local/sbin/hald is also running.  :)

     So now I have both dbus & hald running, and I am using the two X
     options stated above.  Am I missing something?
     Thanks,
     Shawn

On Sun, Jun 21, 2009 at 6:12 PM, Shawn Badger [1]<shawnbad...@gmail.com> wrote:


  Glen Barber wrote:

On Sun, Jun 21, 2009 at 1:06 PM, Glen Barber[1][2]<glen.j.bar...@gmail.com> wro
te:


On Sun, Jun 21, 2009 at 12:45 PM, Shawn Badger[2][3]<shawnbad...@gmail.com> wro
te:


Hi, I've seen several posts with similar issues, but none of them have
helped me resolve my own.  I am using 7.2-RELEASE on my laptop with an Intel
i915 graphics card.  My problem is that Xorg refuses to start (most of the
time) and posts an error in the log:
 drmDropMaster failed: Unknown Error -1

I have gotten X to start on occasion, but I've never been able to get
fluxbox to start.  The command "Xorg -config /etc/X11/xorg.conf -retro"
always works correctly.

xorg.conf:     [3][4]http://pastebin.com/f44c3bfa1
Xorg.0.log:    [4][5]http://pastebin.com/f22d7e99c
dmesg output:  [5][6]http://pastebin.com/f7d02e787

Any help would be very much appreciated.



Try this: [6][7]http://www.dev-urandom.com/user/xorg.php



I didn't realize you had 'AutoAddDevices' in ServerLayout at first..
Still, give "AllowEmptyInput" "off" a shot.




  Thanks for the quick responses:
  @Glen:
  I went ahead and gave it a try - to no avail.  Ironically, I have
  never had any of the mouse/keyboard issues that people have complained
  about.  My issue is that I just can't get X to start - it appears the
  drm driver is failing on me.
  @Francisco:
  I already have both hald and dbus loading in rc.conf.  All of my
  packages have been compiled from ports.

References

  1. [8]mailto:glen.j.bar...@gmail.com
  2. [9]mailto:shawnbad...@gmail.com
  3. [10]http://pastebin.com/f44c3bfa1
  4. [11]http://pastebin.com/f22d7e99c
  5. [12]http://pastebin.com/f7d02e787
  6. [13]http://www.dev-urandom.com/user/xorg.php
_______________________________________________
[14]freebsd-questi...@freebsd.org mailing list
[15]http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to [16]"freebsd-questions-unsubscr...@freebsd.org
"




--
blog: [17]http://sufixo.com/raw
[18]http://www.linkedin.com/in/franciscocabrita

References

   1. mailto:shawnbad...@gmail.com
   2. mailto:glen.j.bar...@gmail.com
   3. mailto:shawnbad...@gmail.com
   4. http://pastebin.com/f44c3bfa1
   5. http://pastebin.com/f22d7e99c
   6. http://pastebin.com/f7d02e787
   7. http://www.dev-urandom.com/user/xorg.php
   8. mailto:glen.j.bar...@gmail.com
   9. mailto:shawnbad...@gmail.com
  10. http://pastebin.com/f44c3bfa1
  11. http://pastebin.com/f22d7e99c
  12. http://pastebin.com/f7d02e787
  13. http://www.dev-urandom.com/user/xorg.php
  14. mailto:freebsd-questions@freebsd.org
  15. http://lists.freebsd.org/mailman/listinfo/freebsd-questions
  16. mailto:freebsd-questions-unsubscr...@freebsd.org
  17. http://sufixo.com/raw
  18. http://www.linkedin.com/in/franciscocabrita
_______________________________________________
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "freebsd-questions-unsubscr...@freebsd.org"

Reply via email to