Hello,

I am trying to find out the temperature of my CPU. After a whole night from dusk till dawn of searching the Web like a furious spider, I got the following results: it can be done via either ISA or SMB, with one of the ports: lmmon, healthd, consolehm or mbmon, and there are also few modules that are required in the kernel: smb, smbus, intpm, ichsmb (TUSL2-C has ICH so this is the one needed) and maybe also iic, iicsmb, iicbb and nfsmb (I have included them just in case). The ones my system reacted at was ichsmb (it finds my ICH) and smb (in creates a /dev/smb0 device). It looks natural enough.


When I'm trying to use mbmon, it fails with:

PSYCHE:~> sudo mbmon
ioctl(smb0:writebyte): Device not configured

I wonder what that means... I think it should work fine with mbmon, but I can't fid the answer what this means.



All the other fail also, and mbmon -I does not work either:

PSYCHE:~> sudo mbmon -I
No ISA-IO HWM available!!
InitMBInfo: Unknown error: 0

PSYCHE:~> sudo lmmon
IOCTL: Device not configured

PSYCHE:~> sudo lmmon -i

 Motherboard Temp               Voltages

 255C / 491F / 528K        Vcore1:   +3.984V
                           Vcore2:   +3.984V
    Fan Speeds             + 3.3V:   +3.984V
                           + 5.0V:   +6.654V
    1:    0 rpm            +12.0V:  +15.938V
    2:    0 rpm            -12.0V:  -15.938V
    3:    0 rpm            - 5.0V:   -6.654V

PSYCHE:~> sudo healthd -d -S
************************
* Hardware Information *
************************
Asus: AS99127F
************************

Temp.= 36.0,  0.0,  0.0; Rot.=    0,    0,    0
 Vcore = 1.71, 1.71; Volt. = -0.66, 5.00, 12.25, -11.65, -5.02

(note that neither of the results seem to be real and they never change)

PSYCHE:~> sudo healthd -d -I
************************
* Hardware Information *
************************
Unknown Vendor: ID = FFFF
************************

Temp.= 255.0,  0.0,  0.0; Rot.=    0,    0,    0
 Vcore = 4.08, 4.08; Volt. = 4.08, 6.85, 15.50, -14.16, -6.12

(the same thing)

PSYCHE:~> sudo chm
ioctl: Device not configured
----------------------------------------
IOCTL: Device not configured
IOCTL: Device not configured
IOCTL: Device not configured
IOCTL: Device not configured
IOCTL: Device not configured
IOCTL: Device not configured
IOCTL: Device not configured
IOCTL: Device not configured
IOCTL: Device not configured
IOCTL: Device not configured
Motherboard Temperature: 0 � C
CPU_0 Temperature: 0 � C
CPU_1 Temperature: 0 � C
IOCTL: Device not configured
VCore:   0 V
IOCTL: Device not configured
Vit:     0 V
IOCTL: Device not configured
Vio:     0 V
IOCTL: Device not configured
+5V:     0 V
IOCTL: Device not configured
+12V:    0 V
IOCTL: Device not configured
-12V:    -0 V
IOCTL: Device not configured
-5V:     -0 V
IOCTL: Device not configured
Fan 1: -2147483648 rpm
IOCTL: Device not configured
Fan 2: -2147483648 rpm
IOCTL: Device not configured
Fan 3: -2147483648 rpm
----------------------------------------



Does anybody know what's the matter with TUSL2-C (I suspect it's a hardware-related problem after all) or what that line about "smb0 not configured" mean?

The hardware works fine (it displays my temperature well in BIOS Setup).
_______________________________________________
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "freebsd-questions-unsubscr...@freebsd.org"

Reply via email to