On Sun, 12 Jul 2009 17:09:24 -0600
Ray <r...@stilltech.net> wrote:

> Hello,
> I'm running FreeBSD  7.0-RELEASE-p3, amd64
> I have never used mod rewrite before, but I am about to be hosting a
> php website that does use it and I can't figure out how to turn it on.
> The website was working properly under other hosting.
> 
> The server has been working properly for over a year with other php
> websites. I installed apache 2.2 along with php 5.2 from ports.
> 
> google says that the following lines should appear in  httpd.conf
> 
> LoadModule rewrite_module     libexec/apache/mod_rewrite.so
> AddModule mod_rewrite.c
> 
> first line does appear, slightly modified 
> LoadModule rewrite_module libexec/apache22/mod_rewrite.so
> 
> when I try to add the second line, apache won't start. 
> 
> mod_rewrite.so is in the location specified.
> 
> at the moment I'm guessing I am missing something in
> httpd-vhosts.conf, but I haven't found a guide for this yet.
>
> Any suggestions, manual sections, links appreciated. 
> Ray
> _______________________________________________
> freebsd-questions@freebsd.org mailing list
> http://lists.freebsd.org/mailman/listinfo/freebsd-questions
> To unsubscribe, send any mail to
> "freebsd-questions-unsubscr...@freebsd.org"

Try with just the LoadModule line. This is the only line I have for
mod_rewrite in my httpd.conf, and it is working properly.

iirc, the "AddModule" linux is apache 1.x specific.

_______________________________________________
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "freebsd-questions-unsubscr...@freebsd.org"

Reply via email to